compositing mask problem..

I’m trying to do a composite with a 3D object behind a real-world object in a pic I took. I followed the tutorial on blenderwars.com to the letter, but when I render the image (which is loaded into the backbuffer) my masked area appears as black, instead of “cutting out” the 3D object to let the real-world pic through. I also tried weirdhat’s tutorial, but that didn’t work either.

Thanks.

I’m not sure what your setup is, but you can also try this: give your object the same texture as is loaded into the backbuffer, and set the mapping from ‘orco’ to ‘win’, and set it to ‘shadeless’.

Been a while since I’ve read that one. Does it say to use the only shadow or env setting for the mask object?

If it’s only shadow, do you have a shadow casting light in your scene? And do you have shadows turned on in the render buttons?