Compositing Misbehaviors .. Subordinate Render Seems to be Fresh and Composted

?Compositor Failure or Operator Failure?

A blender file which currently works and worked many times a few months ago with
Blender beta 2.54 … does not work with Blender 2.57.
2.57 fails while 2.54 succeeds. I tested the file against both versions just before submitting this.

A blender file uses two scenes for compositing.
Scene400 use render information from Scene200
For input one may specify scene and layer in the node.
This worked in the past many times for me in

version 2.54 (sub 0), revision -UNKNOWN-. Release
build date: 2010-10-21, 08:24:42
I do not want to run this older beta for compositing as a long term solution.

The two scenes were a consequence of a file append/link … I believe

The Failure …
When I render in 2.57
I often do a quick one or two single image renders
Scene400 … seems to actually call Scene200 to do a layer render …
Later when I attempt to render a short video …
I sometimes see the subordinate render occuring …
then Scene 400 uses some stale data … so the result is single static image from Scene200 in the final video
The video is failed.

Any ideas for a solution to this problem?
Thanks

version 2.57 (sub 1), revision 36339. Release
build date: 2011-04-26, 15:49:49
platform: Windows:64bit

Blender 2.54 seems to have a problem recognizing a blur size as as relative. I adjusted this manually. Just a detail which is much smaller a problem than the primary 2.57 problem.
Thanks