Compositing not updating

I would like to see the cube’s animation update in the compositing tab, but when i scroll through the timelime, it doesn’t move. when i hit f12, the cube animation updates, but only for that frame.

How can I get the cube to update so that i get accurate playback in the compositing tab?

Render layers do not update on each frame change. This is because rendering a single render layer can often take a long time and lock up the whole system. Blender’s compositor does not support cached playback or pre-rendering for more than one frame at a time. In order to playback the compositing result, you have to render an animation.

However, the Video Sequencer supports frame caching, alpha over, and masks. If your compositing needs are relatively simple, try using that instead of the nodes.

If you only need to watch a simple preview of how your 3D scene looks against background footage, enable “Background Images” in the camera settings.

1 Like