Composition nodes: side-by-side/scale problem

Hi all,

I’ve recently tried to make a small animation of a rotating cube that has some (simulated) bluescreen behind it. But this is not the problem i’m asking about …

When i finsihed the bluesceen setup i also tried to render the original and “bluescreened” image side-by-side by scaling the image to double it’s width and “Alphaover” the two parts.

But the final “Composition” node still uses the size setting of the current scene (which i understand) so only the middle part is shown in the final video-file. Is there a simple way to change the composited size? If i change the scene’s size i also change the size of the two images i want to combine so it’s not really a solution … i already tried using a seperate scene onyl for the final composition, but this turned out similar :-/

Any tips?


Hey buddy! 2.43 will have a scale node. until then, the only solution is to animate and move the camera of each input scene off to one side, like on frame 30 move one left and the other right, so that when you translate them, the dead space is off-screen and the cubes ‘appear’ centered.

1.) I’m using the scale ndoe already and it produces what you see in the screenshot :slight_smile:

2.) i’m not using two camera-inputs, but one input that is displayed next to itself in disguise :wink:


I got my Trix glasses on, but … dont you need two cameras for stereoscopic effect? I thought there had to be some minimal separation between the views…

Oh, you thought i wanted to do a stereoscopic effect :smiley: No, the colors are just a coincidence. This is basically a before/after video - I’m showing the ‘filmed’ scene to the left and the keyed scene with exchanged background (it could also be a show stage instead of just red) to the right. At least i try to show it - save for my troubles with the scale :smiley:


PS: And if you look a bit closer you’ll notice the small blue parts on the cubes that are not keyed and the faint shadows on the ground that are preserved in the final red scene (but could just be dropped if i wanted to). I kinda like the results i got here.

PPS: No i couldn’t get the “Chroma Key” node to work … no matter what i tried :frowning: So i just used the Difference Key node.

maybe fake out compo by setting your rendersize to 1600x300?

Nope, already tried that - it doesn’t work, because then the two ‘input’ sizes and the final composition size are still scaled exactly the same. And using a second (or better 3rd) empty scene with a different size didn’t produce any usable output … but i might’ve used it wrong :-/


maybe doing a final scale in the X direction on the composite? I look forward to your wiki writeup on this new node!!! You certainly will be the xpert!!!

No, that doesn’t work as well. The condensed problem is shown in the green rectangle in my image above.
The “Viewer” node shows how the scaled image looks like (and should be output at the “Composition” node) and the “Composition” node shows how the output actually looks.

Putting a scale node before the comp-node will either crop, distort or shrink (with unused space on top and the bottom) the output depending on the settings - all three options are unwanted in htis case :-/

@all: Is this a bug in the nodes or is there a way to set a different final image for the final composition?


now that you say that, there was something in release notes about the top socket of some node determining the ultimate composition sizing, and that all adds/alphaover/mix are done relative to that top size and that the lower images are NOT sized up or scaled, so mixing a 800x600 with a 400x300 will only mix the middle ‘square’ center; I dont think the node stretches the 400x300 to 800x600. Maybe that is what is happening here…

Hmm, that’s an interesting piece of information … I gotta try swapping top/down inputs a bit or maybe i’ll try the way with the 3rd renderlayer again while keeping this in mind. Thanks.


OK, i’ve investigated this a bit , and this behaviour is pretty much how i used the nodes … In fact the size of 800x300 is inherited (from the "Scale absolute to 800x300 "node) down right to the last viewer node (green rectangular) just fine (which is want i need as output), but the composition node next to it seems to get its dimensions/scales directly from the render-settings of the current scene and not from the nodetree.

I’m now fairly certain that this is just a problem because the scale node was introduced a ‘short’ time ago and this wasn’t an issue before - can anbody (esp. devs) confirm this?
I’m using the cvs build 20061122_noopt btw.


I think this may be a bug. Could you please post this issue to the bug tracker? Remember to include a good test .blend.

Ok, will do … monday that is when i’m fully awake and at my computer with the cvs version again. :smiley:


Added a bug report here