Composition: shadow strikes back

HI, I have a little problem/question. Some time ago I ran over this tutorial on compositing 3d over live footage. However this is quite some versions old and the important button, the OnlyShadow at the transparency panel, seems to have disappeared. There is a rather long solution using the nodes, requiring me to render the image twice, once withou the plane where the shadow is cast and once with it, and the composite the over using the shadow pass and so on… Any idea of something not so complicated?

Hope this helps!:smiley:


Awwh, thanks I haven’t expected it there. That makes things lot easier.

You can add reflection (for more reality) using attachment.:smiley:
In this case Plane must to be with the same form like reflection-surfase from background
image(it’s just like in tutorial,but without OnlyShadow ).The reason is: when you use the OnlyShadow option you loose the part of the reflection that is not in the shadow. The reflexion will only be correct inside the shadow.

case1. with OnlyShadow :add object and its shadow must to cover reflection-surfase
Place it in layer 2 to avoid its rendering or place it out of camera view.
You can change the color of shadow! select the Lamp > F5 Lamps buttons >Shadow and spot panel >Shadow color-settings(default is black)…and follow the tutorial.

2.without OnlyShadow :select Plane(reflection-surfase)>F5 Materials buttons>ZTransp on>Mirror Transparant panel>Ray Mirror on…and add what you like to settings …follow the tutorial.
All the best!


ShadowReflection.blend (546 KB)