Compositor output color is not the same as the source

Hopefully you guys can help me out here!

I am rendering an image in PNG format, that I am then loading into the compositor to form a collage of images. When I composite the image, the result looks different than the original. There seems to be an exposure shift. I have set everything to zero in both the rendered images and the composited image, to avoid this, but it doesn’t help any ideas?



@Bone-Studio helped me out with this in blender chat. I’ll leave the solution here for someone else who might need this in the future

  1. load the images in the compositor
  2. the view transform should be set to “default”

that’s it!

1 Like

Sorry, but what does that mean? “View transform?”

It’s the second option in the color management panel (see screenshot 2 above)

I wouldn’t say it’s a solution, more like a workaround. It is essentially applying transform onto the image, putting it back into compositor and guessing which view transform curve to use in order to get more or less expected output.

Solution would be not to render to PNG but to openEXR to avoid any transforms on the data from render and put that into compositor instead.

1 Like

I tried that, but I never got it to work. I was rendering three 8000x8000 images and then loading them back into the compositor, blender would crash every single time… Probably file size was the issue. Despite png files being quite large, they don’t come nowhere near to exr.

HA! Sorry…I was off my meds that day! :rofl: