Compositor renders Way too much for almost any change

I can’t figure out what caused it. It happened Somewhere along the way when I added a render layer so that I could composite the shadow below the main render because I learned a shadow catcher doesn’t denoise.
So I denoise the image, do a bilateral blur on the shadow, put the smooth shadow under the smooth render, and there we go.

But something happened. It makes sense that the compositor would have to recreate it’s bilateral blur and denoise every time I adjust (although it doesn’t make sense to me if I’m only adjusting things After those nodes, but I’m new here) but I am adjusting the color of a material. And it freezes up my computer About the same amount of time it takes for me to do an actual render. But it’s not actually updating with my changes either.

Anyone have any idea what I might have done somewhere in there? I’ve seen a setting somewhere that said autorender, and the compositor that said autoupdate, and those are not checked. I’m not sure where lese to look. This is Really slowing me down here.

I’m sorry this is happening to you, @kalamazandy. Thanks for sharing what you’ve already looked into.

It might help if you could either share a screenshot of your compositing node setup or share your .blend file (or both).

I’m not able to share the blend, but here’s the node setup:


The jpeg is just to save out previews so I can give them straight to the client right from blender. But since I’m rendering with Filmic, they aren’t white, so that’s what the disabled color balance node was doing. I saw a Bunch of people saying to basically do the same thing to the background color, or make it overbright…but they must not understand how transparent shadows work, because that effects the shadow too much. So this was an acceptable compromise to me…for now. I Do wish you could add a node or option to flip one node to be treated as a different color workspace. Realistically, I’d want to just make two frames. Everything from the render being composited is filmic…then everything in the second frame would be sRGB (and probably clamped), or whatever else you choose. So that you can do all your compositing at once, if you choose.

Sorry I got off track. It seems like the compositor is actually building a new image for every change I do in the scene no matter what, but you can only really notice it if you’ve got something processor intensive…like denoise or bilateral blur. The blur is definitely faster, but still noticeable.