Computer Crashes When Rendering

I’m not sure what is going on, I can’t post the .blend because it is for a client… sorry but i will do my best to explain. I am using Cycles.

My computer:

Intel® Core™ i5-2400 CPU @ 3.10 GHz
(RAM): 4GB
64 bit OS

the scene:

Ve:162066 | Fa:139037 | Ob:1-229 | La:2 | Mem:59.82 (0.25M)

I can render in the viewport (cycles preview) just fine and it is VERY fast; however, when I am ready to render the final scene nothing appears to happen for about 5min. It remains a black box nothing appears to be loading. Then finally it begins to load the BVH and other stuff… not sure. This takes an additional 4min then blender crashes… When in reality I expect a tops of 2min to 3min render time for everything - I am only using 100 samples. Then scene is pretty simple black colored object and a white colored background. I really need to have this fixed soon… Thanks in advance!

Hi, are you using the CPU or a GPU for rendering?

I have a similar problem when using the GPU - it builds BHV and then crashes or I get a BSOD - and the only solution that I got into is to reduce the tile size in the integrator to 512 or 256. In my case it’s a known issuer between WIN / Motherboard / Graphics communication that neither of the builders solve, but your case might be similar.

Hope it helps.

Which version and build of blender are you using?

Sorry for late responsible i’ve been away- started college- but i am using blender 2.63a and GPU for rendering also i haven had the chance to try adjusting the tiles - hoping it works thanks

Does your card have enough memory for the scene? Try it on CPU as a quick test.

Rendering in the viewport is different to rendering overall… your viewport may be one size, and your render settings may be another size… everything has to fit into the ram avaliable on your graphics card. Check your render size that you’re not going too rediculous

Get a program like GPU-Z, and check out how much ram you are using when rendering normally in the viewport.

If you want to try and squeeze hte most out of your computer… get rid of all the 3d viewports, so you cant see any 3d scene. save your file, close blender and reopen, then hit the render button… if you leave the 3d viewports open, blender keeps all the 3d scene in ram in the background.

Thanks a lot ill see if it works, also i’m not sure how to check if it has enough memory- just choose CPU and see if it crashes?

Choose CPU in the render options and see if it crashes (10 or 20 passes) then try with GPU and you will get some answers :wink:
If it renders with CPU without crashing then the problem is with the graphics card - but in this case it doesn’t necessarily mean that the card is “broken”, for what I know a crash with GPU render can be caused by several reasons, from software and drivers bugs to hardware incompatibility or weakness…

good luck

I’ve narrowed it down to my Graphics Card but I still haven’t found a solution… I have a GTX 560 Ti and I have upgraded my computer to an intel core i7 with 16 RAM. I think my graphics card has about 1Gb of memory I only had it for less than a year… I just spent a lot of money on this computer to do complex scenes to come to find out my graphics card can’t render it O.0 Any suggestions? Thanks

If you are not using an official build, pull one down and give it a try. Often those builds from graphicall will crash out. I have also had Blender crash when rendering on a machine that was overclocked.

1gb of ram is a little low; you’ll be restricted on the scene sizes you can render.

Try rendering the default cube - after applying a mat or two - on your gpu. If it renders fine, add a subsurf and turn it up to level 3, repeat render; then try it on level 6.

Re render. If it works, apply the subsurf then add another subsurf.

At level 4 with 25million verts my bloomfield i7 wasn’t a happy bunny - viewport was laggy. :slight_smile:

It rendered in cycles on the cpu quickly, granted it was only a simple diffuse mat; memory usage went from 9.1 to 10.7gig

I changed the mat to glass and added a plane with a glossy mat on it; usage of memory went up 3.5gig during render to 14.1gig

I use amd so cant test the card, but something like the test I’ve performed should allow you test your card and to increase it’s memory use, allowing you to made a reasonable guess at memory being the problem, or not.

Thanks I’ll give it a swing.

Okay, it seems to be a memory problem… now how to fix that? Any suggestions? every thing much appreciated.

Well if you don’t have enough memory, your only option really is to either buy a new GPU with more memory or optimize your scene for lower memory usage. Though I’d think you would be able to render more than 139k faces… Does your scene have very large textures? I was somehow able to render 10,061,800 tris on my 7850 2GB crossfire with SLG2… Or then it’s just a bug with GPU rendering.

Yea I do have like 4 rather larger textures, will lowering the texture size optimize my scene? Ugh I just bought this Graphics card…

Well yeah what I’ve heard large textures can easily eat up a lot memory because they need to be in uncompressed format on the device’s memory when rendering. Though I don’t really have much experience with textures, less textures + GPU :slight_smile:

Do you happen to have any GPU monitoring software, such as AMD GPU Tweak or MSI Afterburner? They can show the memory usage on your GPU and alot more.

I don’t but I’ll look into it.

Check out, it’s great for checing what ones gfx card is up to; download cpu z as well while you’re at it,

Both very useful utilities.

Thanks, I downloaded it, It seems the GPU reaches 846 MB, although my graphics card has 1GB, before stopping leaving me with a black render… Also the GPU load was only at 30 percent - I’m not sure how to interpret that