Computer shuts down during rendering

My laptop is shuting down while I’m rendering.
I guess this is happening because it overheat the processor.

How to make the rendering process more efficient ?

> How to make the rendering process more efficient ?

It is not normal for your laptop to do so. Rebooting when it hits a maximum internal temperature is a safety mechanism that should never occur if everything is working correctly.

Find the slots/holes/grate where air circulates into, and out of, your laptop. Put your face to each one and blow to remove any accumulated dust. If this doesn’t solve your problem then one of the internal fans is not turning. You can either take it apart yourself (starting by removing the screws at the bottom) to investigate or just take it to a repair shop.

You could try decreasing the number of threads Blender is using. Under ‘Performance’ in the render tab there is a ‘Threads’ option. Change it from ‘Auto Detect’ to ‘Fixed’ and try setting that to half the number of cores your CPU has. This includes any virtual cores, so for example if your CPU is a quad core with hyper-threading then there would be 8 cores in total, not 4, which means 8 available threads. So then you would have to set the threads to 4. This will increase render time but it might generate a bit less heat. If that fixes the problem then just keep increasing the number of threads until the problem comes back to decrease render times as much as possible.

I can’t guarantee it will work but if it does it should only be used as a ‘quick fix’. Laptops should never overheat, so if your laptop is overheating then there is some problem with the heatsink, for example a buildup of dust, so you might want to try cleaning it out if you can.

It may simply be the power settings for your laptop. What OS are you using?

Yeah… I had a computer that would shut down during gaming and rendering… it was the heat of my SLI setup. You should buy one of those fans they make for laptops and set it on top of that.

Probably dust collecting in the fans and air intakes. Open the case, and thoroughly clean. Laptops collect a lot of dust over time, so it is essential to remove it every once in a while.

Hey, I was in same situation, computer was shutting down while I was rendering videos in Adobe premiere pro or Sony Vegas pro. Found a way to control power and cooling supply to processor while on power saver+ affinity setting of core! No more shutting down when rendering videos, it’s fixed and 100% working, thank me later.