Compy troubles

Ok, first, i must ask that all who fear/hate really old compies look away and never turn back. I’ve got an old P2-powered Dell Optiplex, from sometime in the mid '90s. It’s got Windows 2000 on it, and recently I installed SP4 on it. I must mention first, that before this “update”, the power module completely failed, and i needed to get a new one.

Now, after updating Windows, i noticed that my CD-RW drive vanished. I have no idea what happened. I only noticed it after the update, and i don’t recall checking it after replacing the power module, so it could be either hardware or software error. Additionally, i have a 60GB external drive (USB, thank god), and while that shows up in the little plug-in drives icon, it doesn’t pop up in My Computer. I’m thinking that the problems may be related.

My hard drive and my floppy drive show up, so i have absolutely no idea what the problem is. The CD drive is connected via IDE cable to the MB, as is the floppy drive, so it shouldn’t be a connection issue, or else the floppy would be down as well (just a guess here).

Anyway, this is all extremely frustrating, as though getting a new computer would be a better option, I have neither the funds, nor the optimal data transfer methods to efficiently move my data (only about a gig, but that’s a crap-load when you’re dealing with a 128mb jump drive). Well, sorry for taking up space, i hope someone here is magnificent enough to help me solve this problem.

The CD drive is connected via floppy wire to the MB, as is the floppy drive,

I am not familiar with old computers but do you mean IDE cables? because IDE cables and floppy cables are different.

Simple check: Go into the BIOS (F2 or delete or F1 on a dell) and look around to see whether the CDROM is detected. If it is, that means the trouble is in Windows. If it’s not…swap the IDE cable, mess around with the slave/master/cable select junmper settings on teh CD ROM, and make sure the power cable is plugged into the CDROM as well as the data cable :smiley:

The USB drive may need to be formatted before Windows can detect it. You can do that through disk management console, sorry but i am not sure where it is located on win2k.

Ok, sorry, yeah, IDE cable. But that doesn’t seem to be the problem. I’ve already checked the bios, tried changing the jumpers, and the power is plugged in. And still, it won’t work. Well, actually, let me clarify that. The tray opens, i can put stuff in an the motor will spin and such, but Windows won’t recognize that the drive exists.

Also, the usb drive is already formatted (i have a ton of stuff on there, from a friend’s computer, etc.) so it works on other computers, just not mine (or another oldie I have, though that one’s a laptop). I did find a fix, but I think it was only for Windows XP, and involved a specific registry item that I could not seem to identify in my system. Thanks for the effort though! Alway appreciate input, as long as it’s constructive.

so the CD is detected by BIOS, but not Win2k? If you go under device manager, do you see the CD drive listed? (with a red or yellow flag, hopefully?)

as for the USB, has it ever worked before? Win2k might have some trouble w/ USB2.0, and I don’t really know what to do in that case.

I remember the problem, something that happened a lot with older versions of Windows on older hardware. I can only give you a few pointers though.

  1. Try and use Windows NT4 Workstation instead. It is stable and will run much smoother on your pc.
  2. Play around with the jumbers on the back of the hdd and the cd. Also try different configurations of the cables - ie: connect both hdd and cd to the same ide cable and into ‘IDE 1’ slot or each one on a seperate ide cable with hdd into ‘IDE 1’ and cd into ‘IDE 2’
  3. Make sure you use the old ide cables, the old one have 40 pins and the new one 80 pins. You can see the difference.
  4. USB: make sure your have the latest service pack installed.

Faust, if you used the Enter button to add a few line-breaks, your posts would be a lot easier to read and would likely get more responses.

A large block of text is visually difficult to follow.

Just an opinion

Ok, sorry about that. Fixed my previous posts. Anyway, no, my cd drive doesn’t show up in the device manager, but my USB hdd does, but not in My Computer. I do have a small USB jump drive that does work in my USB ports (1.1, but has a 2.0 hub connected to one port, the other has a USB mouse in it).

About the cables, they came with the computer, so it’s impossible for them to be a different model (the computer is a business model, and had resided in one until a few years ago). I haven’t changed them around at all, and I think I would know the difference in number of pins (what in the world needs 80 pins!?).

Also, I believe I mentioned playing around with the jumpers, but no configuration worked with the cd. Should I switch around both the cd drive and hdd’s jumpers? And about the USB service pack, wouldn’t that be included with Windows 2000 SP4?

Lastly, NT4 is out of the question. I understand that would cost money, which I don’t have a lot of. That, and time. Even if I were to download a pirated version, I’d be dead before it ever finishes, because I’ve got 56k internet. So, changing OS is a no-no.

Thanks for the input, still need help though.

  1. Make sure you have the latest service pack for Win2000 - I’m not sure if sp4 is it.
  2. Try different configurations with the cables and jumpers. Connect the hdd to ide1 and set jumper as master (not cable select). Now do the same with the cd, but connect to ide2 (also as master)
    That is the first option I would try. If that doesn’t work, try different configs with the cables and jumpers.
  3. Make sure you run the ‘harddrive auto detection’ in your bios, after every change in config. Older pc’s did not always just do it automatically.