Concept RPG (0.11 released! Linux too!) [BGE Competition Entry]

Got a Linux version ?

Microsoft Visual C++

There is also the msvc++ redistributable which has files needed to run msvc apps. I’m trying to find a way around needing the redistributable.

A Linux build will come when I get a few more issues resolved. I want to get the game working right with the latest SVN so I can do a fresh checkout and build in Linux. I hope to have this resolved by this weekend :wink:

Hey, just letting people know, we’ve been posting updates here:

We will make sure to post major news here on this thread, but if your interested in some of the more minor things, go ahead and check out the site. Also, for those want it, there’s a link to an RSS feed on that page.

Cheers,
Moguri

0.10b has been released! From our project’s news page:

"We’re releasing a bug fix build to 0.10. The Launcher.exe no longer has the annoying dependencies and should work for everyone. Also, the runtime has been updated to the latest SVN, which also fixed a couple of problems when running the game from the runtime (game.exe). And one more thing, which isn’t that much of a bug fix, but the second skill (currently referred to as Whirlwind) now can hit multiple targets.

Sorry Linux users, but we’ve hit a few more snags. I’ve got a runtime made, but there seems to be library issues. I’m working with some people to get this sorted out. We will have a Linux release for 0.11.

Head over to the downloads page to get the new version!"

Your game looks fun, the shader is very nice.

I had Linux issues with pit monsters. Blendenzo helped me with a fix, create a new scene and run this before anything else:

import site
site.addsitedir(GameLogic.expandPath("//"))

That is if your library issue is to do with having trouble importing modules.

andrew-101:
Thanks for the tip, I’ll give it a shot :smiley:

This game looks good, but I had a few problems getting it to work. After the loading screen, the HUD appears but everything else is black. The python console also give me this error:

Python script error from controller "updateHUD#CONTR#1":
Traceback (most recent call last):
  File "updateHUD", line 25, in <module>
  File "D:\Desktop\dc-svn	ags\crpg010b\Windows\Data\GameLib\hud.py", line 78, i
n updateTarget
RuntimeError: 0: Texture material is not available

C-106 Delta:

Thanks for pointing this out. I went and took a look at the code, and am now uncertain as to why it didn’t crash on my system.

Anyways, replace Data/GameLib/hud.pyc with this one:
http://www.daboys4u.com/crpg/hud.pyc

That should solve the problem.

If anyone else is having problems with anything, please speak up. We can’t fix things we don’t know about :spin:

Cheers,
Moguri

Looks good, but it wont work…
And I dont find the problem, but it look really cool.
So… Congratz!

Jesus (I’m wondering how you managed to get that name o.o):

If you could be a bit more specific about what your problem is, I could try to fix it. Also, I may have to update the download link in the original post.

Hey, I’d love to try this out. The only problem is that after I download it and run the launcher, I get told that it cannot find either MSCVCP80.dll or MSVCR80.dll. Any idea as to what’s going on?

ArcaneLight:

Please make sure you’re trying 0.10b

I was hoping all the dependency issues were resolved for 0.10b since I used MinGW to compile the Launcher.exe. If you’re using 0.10b and still having issues, you can also run the game with Data/game.exe. It defaults to 800x600 fullscreen, so you may want to run it via the command line:

cd path o\exe

then:

game.exe -w 800 600

use “game.exe -h” for more information

Thanks for your interest :slight_smile:
Moguri

I tried version 0.10b and I replaced the pyc file. However when I try to play the game, everything (except the hud) is black. The console window didn’t say much except:

Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Detected GL_ARB_multitexture
Detected GL_EXT_separate_specular_color
shaders not supported!
shaders not supported!
read library: lib //..\Libraries\dungeons\ShipRuins\dungeon.blend
read library: lib //..\Libraries\players\players.blend
read library: lib //..\Libraries\monsters\Slime\SlimeMonster.blend
read library: lib //..\Libraries\players\Heal.blend
shaders not supported!
Added cam OBCamera

Here is also a picture of the game:

Attachments


C-106 Delta: Does your card support GLSL? This requirement was not listed in the first post originally, but Moguri updated it with the requirements

Does your card support GLSL? This requirement was not listed in the first post originally, but Moguri updated it with the requirements

No, my card does not support GLSL unfortunately.

I added some screenshots from the project site to the post as attachments. Now people don’t have to dig through all the text to find the link. There are still more screenshots here though:

Cheers,
Moguri

From the project site:

Alright, 0.11 has quite a few changes. Here is a snipit from the change log, which can be found in the readme:

0.11
· Linux build (64bit runtime supplied by EruditeHermit)!
· Windows runtime updated to Blender revision 19351, the same version as the Linux 64bit runtime. The Linux 32bit should not be far behind this.
· Camera scaling added (camera gets closer to player as he gets close to a wall)
· Whirlwind has a new effect and is now controllable (character can move while using Whirlwind)
· Move to attack (the player will move into range to attack while the attack key is held down)
· Dungeon chambers were optimized (face count was reduced, which leads to faster load times)
· Better lit dungeon
· Monster tweaks (he is now a little faster, and not so sluggish)
· Updated monster’s death animation (he doesn’t pancake now)

Head over to the downloads page to get the new version!
Please give us some feedback!

Cheers,
Moguri

I shall take a look when I get home:yes:

Just tried v0.11 on my Kubuntu Jaunty 64 bit Linux machine and it works beautifully.

Silky smooth, toon shaded goodness all the way (and this on an ATI card too! :D)

Thanks Moguri / EruditeHermit!

Thanks for the comments, but don’t forget Kupoman! He’s responsible for the toon shaded goodness :smiley: