confusion w/ NLA

I have a walk cycle for a character of mine that i want to use in an animation, but i dont want this to be the only action i use. afaik, this is the reason that there is an NLA editor at all. But i have a problem when i try to add an action strip to the NLA. As i understand it, you select the object that is being animated (in this case i think the armature?), place your cursor in the NLA window and press SHIFT-A. I see a menu come up and i select the desired action from it, but no strip appears in the NLA.

i’m using blender 2.46 svn… do you think that might be why? or ami doing something wrong?

thanks for your time


i tried making a very simple rig (just a lengthened and subdivided cube) and a really basic action, and the actions appeared in the NLA as i entered the keyframes. for my character, however, this never happened, and nothing i do seems to be able to get the NLA window to display the armature. It remains entirely empty no matter what i try :frowning:

addition: i have been messing around and searching the forums, and not much has shown up, although i did find some temporary hope with the ‘convert to strip’ command. But i think the only obstacle between me and getting the NLA window to work is that when i select an object or an armature, the NLA window doesn’t list it, even when i make new actions or add new keyframes.

when i look in the outliner, my armature has nla strips assigned to it, but since all of the organization of animation is done visually, that’s not much help.

well i solved it.
I was running some preview render tests, and on my first render, everything was white. Since the internal renderer was only registering sky, i went to the first sensible place to look for errors: the render layers panel in the render buttons window. sure enough, only one layer was enabled, and it was one that was occupied only by empty space. I disabled this layer and enabled the two layers which contained most of the scene, and then up pops a name in the NLA window. it was the name of a material in the scene which i had keyframed to change colors. It was then that i reached my pathetic state of enlightenment. for whatever odd reason, the NLA window only displays data for objects within the enabled render layers.

but nobody cares. nobody bothered to help me in my time of need. nobody’s listening.

im going to go jump off a building.

…that was a joke.

hi. about the NLA and render layers - that was weird.
about the jumping off part, I’d send flowers, but…

NLA editor / view menu / “only objects on visible layers” option (on by default), turn off to have strips visible regardless of layer settings.