Connecting Blocks in Logic Editor - can't drag & drop: Tried EVERYTHING!

First time on this forum & Im a bit of a newb on Blender.
But Please Help! Ive been trying for 3hours now!
Im trying to get a cube to move across a plane.
(The annoying thing is that its something Ive done a dozen times before on a different PC at work.)

Im using Blender 2.62 (which Ive already reinstalled but that didnt fix it)
Im in Blender Game mode.
I have the cube set to be a Dynamic Object.

Im in the Logic Editor -
I have a sensor ready to check keyboard letter W.
I have a controller set to AND.
I have an actuator set to increment the x location by 1.

I CAN’T LINK THE BLOCKS TOGETHER. :no:

If anyone can help - I’ll buy them a beer over PayPal! lol

the usual way is to drag from one connector on the right of a logic brick to the connector on the left of a logic brick. Be aware your system mouse cursor should be exactly over the target connector.

The dragged line is sometimes a bit “mis-drawn”. The system mouse cursor is what counts.

So, it makes a change to see a user who seems to have put some thought into what isn’t working :slight_smile:
First thing’s first:
How are you connecting them?
Check this picture:


The method on the left is used for changing the controller, or just linking to a controller, whereas the method on the right is new to 2.5 / 2.6 and adds the last added controller type if you are using it to link a sensor to an actuator

remark:
It adds a controller of the type added last.

Yes, in fact i noticed this yesterday.

Running 2.4x with a certain Intel video driver I once encountered a problem where links were invisible, but the logic still existed.
Not sure if that’s still a valid problem with 2.62

I once had a similar problem and it took me while to figure out. I think it ended up happening because I was some how editing an object that didn’t exist. I can’t seem to replicate this problem in a current build of Blender, so it is likely unrelated.

in my blender 2.6.0

the blank line is too short from left to right
and too long from right to left

with a error about 10% (with a big zoom the error can become 2/3 cm on the screen)

the cursor is right instead as say Monster

also the “range of target” (when the button is released) seem a bit too little

I am having this problem too, the link exists but i cannot see it, it gets very confusing!

Wow! What a great board. :sunglasses:
I honestly didn’t expect a reply let alone several! THANK YOU VERY MUCH - all of you. 8-D

I have to admit after trying for a number of hours to fix the problem I “cheated” & dug out an old laptop (with XP on it!), installed Blender 2.6 on that and now I have a cool 2 screen setup. :sunglasses:

Since the problem doesn’t exist on the 2nd laptop I’ve managed to get loads done on that & have subsequently ran into ANOTHER problem…lol

Ive posted the problem on another thread but can I just say THANK YOU again for such a great response -
I freaking LOVE open source/freeware and the goodwill that goes along with it (all the youtube tutorials to help you learn how to use it) & I know it sounds OTT but this has just reinforced my belief that the web brings out the absolute best in people all wanting to learn together!! :sunglasses:

Just a little tip, if you edit your first post and go to Advanced you can mark the thread as Solved. :wink:

Another issue that I have seen is that the rendering of the links as you drag them is not quite right sometimes too, the line for the link does not join up with the mouse, if you drop the mouse onto the connector rather than what appears to be the end of the line the link will be established.