Constant Audio Problems with Video Sequence Editor

I’m editing a ‘Star Wars’ fan film and I’ve been trying to export Hi-def video (1694 x 720) and every single time I’ve had problems.

The input file is a .AVI with an .MP3 audio codec (256 kbps).

Every single time it’s rendered, there’s either (a) no sound, (b) very gravelly sound, or © the video is black.

I’ve tried every permutation of codecs I can think of. No matter what, there’s ALWAYS some darn glitch. I’ve been fiddling with this for hours and I can’t solve it. Assistance is HUGELY appreciated.

I don’t know if this will factor into any advice, but here’s the full video properties of the type that I’m trying to render in Blender:

Format : AVI
Format/Info : Audio Video Interleave
File size : 9.37 MiB
Duration : 17s 6ms
Overall bit rate : 4 622 Kbps
Writing application : MEncoder Sherpya-SVN-r32492-4.2.5
Writing library : MPlayer

ID : 0
Format : AVC
Format/Info : Advanced Video Codec
Format profile : [email protected]
Format settings, CABAC : No
Format settings, ReFrames : 2 frames
Codec ID : h264
Duration : 6s 235ms
Bit rate : 4 000 Kbps
Width : 1 694 pixels
Height : 720 pixels
Display aspect ratio : 2.35:1
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.137
Stream size : 8.82 MiB (94%)
Writing library : x264 core 107 r1745 4785e8e
Encoding settings : cabac=0 / ref=2 / deblock=1:0:0 / analyse=0x1:0x111 / me=umh / subme=6 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=0 / weightp=0 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=abr / mbtree=1 / bitrate=4000 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00

ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Mode : Joint stereo
Mode extension : MS Stereo
Codec ID : 55
Codec ID/Hint : MP3
Duration : 17s 6ms
Bit rate mode : Variable
Bit rate : 256 Kbps
Channel(s) : 2 channels
Sampling rate : 44.1 KHz
Compression mode : Lossy
Stream size : 531 KiB (6%)
Alignment : Aligned on interleaves
Interleave, duration : 29 ms (0.69 video frame)
Interleave, preload duration : 551 ms

First read latest blog entry in my sig below. Try aac for audio. Also some codecs need just the right dimensions to work.

Your dimensions do look strange. But give the xVid codec a try, it is more forgiving of weird sizes.

Zero progress. Now, on top of the three problems I had before - either gravelly sound, no sound, or a black video, I’m now usually not even able to render in the first place as I just get that “Error Initializing Video Stream” notice.

Hilarious new entry in this comedy of errors: Now it’s just rendering one frame constantly, but the audio is great!

Have you tried the default settings just to see if they work? They have standard settings just to start with. Then you could trouble shoot from there.

I believe that I was at the default settings initially. It started off as render as a .PNG image, then I went to the .AVI codec, and then, well, it never worked.


I believe that I might have “fixed” the problem. I was importing the ‘Star Wars’ footage from a conversion program called ‘Any Video Converter’. I was converting from .MKV to .AVI (I think the only video form Blender accepts). I’ve been using this conversion program for a long time and never had any problems at all. But I was so frustrated I got a different program (Wondershare) and used that to convert the .MKVs to .AVIs.

Now, it appears to be okay. (Although I feel like it’s a horror movie and the slasher’s gonna rise from the dead!)

This whole ordeal has been so frustrating the past two days it’s seriously made me consider switching to Linux so that I can use Cinerella or OpenShot for video editing. But I don’t have any coding knowledge at all, so I think that might be a bad idea.

So you had a source problem then rather than a rendering issue. Did the scene playback ok in Blender while editing?

I have a long way to go before I’m done editing.

What I was doing was, since I don’t know how to use Proxies in the edit (substitute smaller videos for ease-of-use, then have the program draw upon the larger videos when actually rendering), I was instead breaking the large videos up into chunks using that program, Any Video Converter. Then, just to make sure that everything would be okay, I tried to re-render them in Blender. It was at that point that the nightmare began.

Also, in defense of Any Video Converter, I’ve used that program many, many times for every type of media file imaginable, and I’ve never had any issues at all until this, and the videos played perfectly well on their own. It was only when trying to export them through Blender that there were problems.

There wernt copyright protection issues with the source pics? Did you play them all the way through in a media viewer to check before placing them in Blender?

I don’t think that any copyright issues were a factor at all, and the initially converted .AVI files did play okay in regular media players. (Although they played very, very slowly, but I think this was just because my computer plays large .AVI files slowly often.)

Blender was recognizing them: in the VSE’s preview window, they would show up (usually; and I couldn’t really say about audio because the preview couldn’t play them quickly enough for legible sound). It was only when they were rendered that I had the problems.

Have you tried just editing in blender (use the proxies if your PC is a bit slow), then encoding the video and exporting the audio separately, then muxing them outside of blender, that way you’re not constantly re encoding your video stream every time you try to get the sound working?

Your source looks like some illegal rip, down scaled and converting the audio to mp3. I’d have thought a 2:35:1 would have been 1920 by 900 and something, not 1694x720, then the player adds the letterbox etc.

I’m not into all that world of ripped movies but personally if I was putting the effort in I’d go back to either the original DVD or Bluray source, rather than some dodgy remux mkv to avi of a dodgy hacked conversion. I’m pretty sure mkv container is supported by ffmpeg in Blender anyway and is a better container to use generally.

Then I’d extract the audio stream as original format without degrading it to mp3 and re encode the video free of restriction to some intermediate file like lossless h264 or utcodec (as it’s now supported by ffmpeg), edit and export video and audio separately then mux together later externally.

First, I don’t yet know how to use Proxies. I’d be thrilled if you could direct me to a good tutorial of any sort. (I tried toying with it and couldn’t get it to work - it was always drawing from the same video I had in the timeline no matter what.)

Second, I don’t why you brought up your guess that it was an “illegal rip”. I appreciate your assistance, but I don’t believe it’d be good for the forums if people are just randomly throwing around words like “illegal” and jumping to accuse people of “piracy” or whatever. I don’t think that that would help anybody in need of assistance in any way. I’d guess that the main effect that would be making people suspicious of other users and make some people afraid of asking questions because they think they’ll be accused of something. That’s just my own opinion.

Third off, the source file was a .MKV and I do have the ffmpeg codec on my computer, but I couldn’t import the .MKV into Blender. But I then downloaded 2.6 and now I can import .MKV. (But now I don’t necessarily have any use for it!)

As far as separating the video and audio tracks, I don’t want to do that because, for me, I’m having enough trouble learning Blender’s VSE as it is, without adding the extra clutter of doubling up the number of files that I’ve gotta import and mess around with, ya know?

For whatever reason, just using the different program to convert from .MKV to .AVI worked fine. I don’t know why the .AVI files from the Any Video Converter program weren’t working - just one of those weird, frustrating mysteries as far as I know!

If anybody can direct me to a good tutorial in proxies (or even give a good summary yourself) I would appreciate. My searches for it have not yielded too much at all.

Proxies have been buggy for me on Windows 32bit. Corruptions of TC values can cause weird behaviours and kill playback all together. But when they work it is really cool. I don’t think that there any examples around yet, although there was a simple demonstration video from the developer of the tomato tracking branch, as it is integrated there too.

Thanks, 3PointEdit. I really don’t have much of an idea about who that might be, but if you could possibly take a minute to track down that Proxy tutorial, I’d be really grateful.

I didn’t accuse you of piracy, or randomly throw accusations I was making the distinction between a dodgy conversion like an illegal and a decent source, which I’d work from.

Frankly I give a f–k if its legal or not each to their own, I’m not judging anyone. I got nothing more to say, use whatever source and tools you like of no more interest to me.

Alright, maybe I jumped to conclusions myself! I don’t want to start any bad vibes or be ungrateful for all the assistance I get from these forums. So I’m happy to move along, too. Looks like we just had our wires crossed, but no big deal at all.

Here ya go I hope it is of some help:

Thanks, 3PointEdit.

I’ll be diving into the Proxy issue soon, and I’ll come back and try to learn from those videos when I do. Greatly appreciated.