Constant Crashes When Editing: Solved (Probably)

Edit: Thought this problem was solved. Nope. Still crashing. Going to continue to attempt to troubleshoot.
I believe I have already solved my problem, but I spent so much time with it, that I wanted to post my experience/solution here so that if someone experiences similar error codes this might show up in their search.

I’ve suffered repeated crashes, and I was not able to replicate the problem crashes after moving all the objects in my scene to a new file and disabling add-ons; this is a fancy way to say “that fixed the problem”, as far as I can tell. I was able to immediately replicate my problem of crashing by then enabling Time Tracker and Loop Tools (occurred 10 seconds after translating objects around). Although I had tried disabling non-standard add-ons earlier and still replicated the problem of crashes, I had not tried both moving all the objects to another file and disabling add-ons; while I only tried these steps individually, I still experienced crashes.

What is so confusing about all of this is that for a while Blender was stable with Loop Tools and Time Tracker, I doubt this was a coincidence. The crashes seem to occur far too quickly for me to be mistaken in my belief that something else must have changed for these add-ons no longer to be working smoothly with my version of Blender.

System Specifications
CPU: AMD FX-8320E Eight-Core, 3.2 MHz
OS: Windows 10 64-bit
Installed Memory: 16 GB
DirectX Version: DirectX 12
Motherboard: ASRock 970-G/3.1

Description: I’ve been working with Blender for at least 6 months, and have had no serious technical problems with it before. In late June, I heard about the Principled BSDF shader for Blender, so I installed the 2.79 test build. Sometime in July, I installed an add-on called Time Tracker, earlier than this I also enabled Loop Tools. Up until the past week, i.e. August 1st until today the 8th, I was still having no technical issues with Blender.

I made no changes to Blender 1-3 days before I began to experience crashes the past week. In a few cases, the crashes happened so consistently after a short period that I made no significant progress in the model pictured here before I crashed almost in the exact same process.

I would grab 4 vertices, extrude them, move them, trying to form a specific shape, and after about 2-6 extrusions, the file would crash as I was moving the vertices. This must have happened at least 4 times on the same day (after having experienced several similar crashes in the same spot the day before). Said scene I am working on only has 5k verts.

I have gone through a long list of what seemed to me like obvious troubleshooting steps, none of which have resolved my problem(s?):

  • I upgraded my GPU drivers from Nvidia’s website. I later repeated this step
  • Uninstalled and reinstalled Blender twice, version 2.78c.
  • Updated CPU/Chipset drivers from the Motherboard manufacturer’s website (I assume this included CPU drivers as well as chipset, I was not able to locate any drivers for my CPU on AMD’s website).
  • Obviously, I’ve restarted my computer several times in the course of this process.
  • Tried disabling Time Tracker after erasing all its data, as well as Loop Tools, the only non-standard add-ons I use with Blender.
  • Tried disabling every modifier on ever object in the scene I was working on. As well as unhiding objects and deleting ones I didn’t need.
  • Tried making a new file and importing all the objects I needed via append. Still crashing. Confirmed several times.

After doing these steps, I’ve tried to narrow down what is causing the problem. In a new file (using my default file, at least), I was able to subdivide a cube, sculpt it, and extrude it, with 90k verts, no crashes while in sculpting. I was able to extrude and use translate (“g”) to move large sections of the mesh with no problems. Only by playing around with the translate tool for a long time was I able to get the file to crash/replicate the problem. I was able to play around with a 100k cube in the old scene I’ve been working on and having problems in, but this did not make it crash. I have confirmed that my CPU utilization and memory usage were never even close to 50% when the crashes occurred, usually CPU was around 24% and memory usage at about the same level. I plan to run a memory diagnostic after this post, even though I expect my RAM to be in good condition. Also running MalwareBytes.

I haven’t yet tried to see if I could replicate the problem while disabling all other running applications (e.g. Google Chrome web browser). Despite my initial hunch that the problem was unique to translation operations, it has also occurred during extrusions.

Here are the two logs from a crash from Event Viewer. I compared with other crashes from Blender and these error logs seem to all be roughly identical, same message with minor changes in numbers (e.g. fault offset).
Windows Error Reporting
Fault bucket 120811037824, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: blender.exe
P3: 58b0588f
P4: StackHash_def4
P5: 10.0.14393.1532
P6: 5965abad
P7: c0000374
P8: PCH_A4_FROM_ntdll+0x00000000000A6BF4

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: d06fe3ff-62c0-4d04-a418-f49ddbc85369
Report Status: 1
Hashed bucket: 867e1e8dbbb18d82f20ebe3352b9d1f1

Application Error
Faulting application name: blender.exe, version:, time stamp: 0x58b0588f
Faulting module name: ntdll.dll, version: 10.0.14393.1532, time stamp: 0x5965abad
Exception code: 0xc0000374
Fault offset: 0x00000000000f8363
Faulting process id: 0x1ee0
Faulting application start time: 0x01d310aa9c48fa8c
Faulting application path: C:\Program Files\Blender Foundation\Blender\blender.exe
Faulting module path: C:\WINDOWS\SYSTEM32
Report Id: d06fe3ff-62c0-4d04-a418-f49ddbc85369
Faulting package full name:
Faulting package-relative application ID: