constant procedural noise

i tried noise, clouds, etc… and found that when render it does generate different noise on each frame!, also tried with the different mapping types, same result!
how to fix it?? any ideas will be welcomed :slight_smile:

One approach I find useful is to bake the noise to an image texture. It generally uses less RAM and renders faster to do so, and is of course very stable when UV-mapped.

clumsy but working, although i mangled to do it, and the baked texture are bigger than the original one, i tried to bake to 1024 and 2048 sizes, same result.

thanks for helping.

but still looking for a better a broach.

you might be able to control the noise gen by doing a script and re using the same noise value i think
if not available yet then ask for it as a new feature

see API

if you sue all the same parameters i think it gives the same pattern
there is not random root here

i vaguely remember something about this in 2.49 2 years ago
but have to look if i kept any doc on this !


thanks all

@@RickyBlender: sorry man i didn’t understood anything from you, can you make it clearer :slight_smile:
for now i gone with the bake option, but if there are another solution, it will become handy in the future .