Control which objects cause shadows on certain other ones

I have two Buf. Lamps in my scene. One lamp allows my character to cast shadows onto the environment. the other one allows my character to receive shadows from the environment. The second ‘Receive Shadow’ lamp is also casting shadows from the environment on to the environment. I have already baked the shadows into my environment, so I do not want it doing the shadows again (the ones I baked in are higher quality and have AO)

You can control light/shadows selecting your Lamp, and then in “Lamp” and “Shadow and Spot” panels enable/disable the “Layer” and “OnlyShadow”) butons and moving your objects to different layers…?

I already have them on different layers with some having ‘layer’ and other having ‘onlyshadow’. that won’t fix the problem though. I want an object on one layer to cast a shadow onto an object in another layer, but don’t have that object casting any shadows onto objects in its own layer.