Controling anime Style shadows on individual meshs in Eevee

This is my first time posting but my main issue I’m having is controlling the shadows on each mesh. I’m going for an anime style animation and in anime, the shadows on the characters don’t act normally. What I need help with is using a bone or driver, or both, to control the shadows on the meshes themselves, like with sun lamps but only on that one mesh rather than on all meshes. I know it can be done as I saw a video where this guy uses a custom shaped bone, at least I think it was a bone, to control the shadows on the individual characters, but he didn’t show how he did it, and it was a trailer for his animation course, which is $100. I’ll be using a normal sun lamp for the shadows on the ground as I already know how to do that.

So can someone help me here, I already made a decent anime style shader, but it’s the shadows I’m struggling with. Oh, any other anime style blender times will be helpful too.

If this helps I’m using blender 2.91.0 and the Eevee render engine.

Try this node setup as the normal input for your shader (note that the Layer Weight value should be 1):


It’s a bit crude, but it does allow you to change the rotation, position, and amount of shadow on individual objects to some extent. You can do this by dragging the sphere around, which you can keyframe or add a driver to. Ultimately, you’ll need to change the normals in some way. This is just one quick and dirty example of how you can do that.

Here’s an even better way, or a way you can combine with a node setup for perfect control: use the Normal Edit modifier. Just add an Empty and then set the target of the Normal Edit modifier to that empty. This will make the normals point at the Empty, and you can put that on a bone or animate it however you’d like. (You’ll probably want to turn down the Max Angle, you can find that in the Mix dropdown in the Normal Edit modifer)

Thanks for the quick reply. I’ll keep messing with it, but it seems it doesn’t play well with rim lights.

Do you mean the nodes or the modifier? The node setup is far from a fully developed solution, I’m not surprised it doesn’t work for your case. If it’s the modifier, it should work with rim lights, but that may depend on the complexity of the model. I’ll do some tinkering and see. I found that setting the Max Angle to 40ish really helped with shadow quality; might work for what you are doing.

I think the node setup doesn’t work because of my shader, tho I’m not sure because I’m still new to blender, and the modifier didn’t play well with rim light for me but ill try the 40 on to see if that helps.