Converting from 3ds to blender

I downloaded the blender converter from (under the plugin section) but it won’t import 3ds files like it says it does on the websight. I might have to start converting lightwave models but on most of the models are in 3ds. What should I do

Well, I’m a newbie myself … and probably not the right person to answer you … but I downloaded the latest stable Blender release (2.34) and it comes with the 3DS importer. I have used it without problems (although not really impressed with the models I loaded). I just select File -> Import -> 3D Studio.

Hope this helps.

The first thing you should do is not expect everything to work … sorry … I didn’t try the converter myself yet…but I tried to import some AI files into blender using the new import functions…

Everyone said that they worked… but hell, with me they didn’t… I ended up working around through wings in order to import the outlines of 1 freaking letter… took me all day to figure that one out…

Importing 3DS into blender, I am going to try that one soon …


There is no 3ds import in that list. But there is some way out there because the blender models I downloaded from showed in their descriptions that they were converted from 3ds. I’m really starting to get cheesed off. This one little thing seams to elude me at every turn.

If you are using Blender version 2.34 simply select File -> Import -> 3D Studio. Then select the .3DS file that you wish to import. It couldn’t be easier. If you don’t see an entry in the import submenu for 3D Studio, the name of the import script is This script can be obtained at this link:

You might as well grab the 3DS Export Script while you are at it.

After downloading the script, put it in your default script directory. If you used the standard install, this might be Program Files/Blender Foundation/Blender/.Blender/Scripts (true for Windows install only). Then you need to change one of your Blender windows to a scripts window (has a + and - sign icon next to it), then select Scripts -> Update Menus. Now you should be able to select File -> Import -> 3D Studio to import your .3DS file.

If this confuses you, I might suggest you select Help -> Manual and study up on the Blender interface and navigation tools available to you. Importing and loading/running python scripts is covered there as well.

ok. but i’ve loaded an object but there is no object…
either it is in space or its size is very small… …any ides how i can find it??

Check the other layers. You can use the ~ tilde key to show all layers at once. If that doesn’t work, then use the numeric keypad + and - keys to zoom in and out looking for the object.

I don’t know if this will help but I have found it very useful for converting files from one format to another. I’ve used this to convert 3ds into DXF so I can import them straight into Blender.

I couldn’t see an import option for 3ds files in Blender either, but will check out the script to see if this helps

Try exporting the 3Ds file to ‘WRL’ and then importing it into Blender.

To get Blender models into Max I export as VRML1 and then import into Max with ‘WRL’.

with this script, I get the following console error:

reading the first chunk
reading a chunk
found a VERSION chunk
version: lenght: 10
Bytes left in this chunk: 226672
reading a chunk
found an OBJECTINFO chunk
object info: lenght: 224982
reading a chunk
skipping to end of this chunk
Bytes left in this chunk: 224966
reading a chunk
found a MATERIAL chunk
Found a MATNAME chunk
material_name: Eng Eng
Bytes left in this Material chunk: 165
Found a MATDIFFUSE chunk
Bytes left in this Material chunk: 150
Found some other Material chunk: 0x903e
Traceback (most recent call last):
File “”, line 456, in my_callback
File “”, line 445, in load_3ds
File “”, line 389, in process_next_chunk
File “”, line 417, in process_next_chunk
File “”, line 353, in process_next_material_chunk
struct.error: overflow in item count

Any ideas?

Thanks! :slight_smile: