Copy Paste py. Script In Ubuntu 12.04

I’m trying to copy paste a python script from my home folder in File System/usr/share/blender/2.62/scripts/addons but it won’t let me paste.

When I go to right click/properties/permissions it says"You are not the owner, so you cannot change these permissions."

How should I do this? Is there a terminal command? or is there something easier ?

Hi, you can try to install the script in user preferences > addons or:
Use a zip version of blender, or in terminal:

sudo chown -R yourusername:users /usr/share/blender/2.62/scripts/addons

Cheers, mib.

First I tried with the terminal command but it doesn’t work. maybe I got the “yourusername:users” part wrong. Anyway what does this do ? I would like to know how to do this in the terminal .
Next I tried with the user preference>addons>install and it works !
Cheers !

Cool, chown (change user/owner) is used to get write permissions in /usr/share/blender/2.62/scripts/addons.
The folder in /usr are only write able for superuser (root) and you can change this with chown or chmod.
It is like in windows regular user can´t write to C:/.
Type chown --help or man chown for for explanation.

Cheers, mib.

So if I want to let’s say paste a .xml file from home/documents/blender/customize to usr/share/blender/2.62/scripts/presets/interface_theme as there is no way to import .xml files directly from blender user preferences exactly what should I write in the terminal ?

I tried like this:
[email protected]:/# cp /home/msm/Documents/Blender/Customize/cycles.xml /usr/share/blender/2.62/scripts/presets/interface_theme/

it puts the .xml where I want it but in Blender/Themes/Presets it won’t load up it gives an error:

Traceback (most recent call last):
File “/usr/share/blender/2.62/scripts/startup/bl_operators/presets.py”, line 195, in execute
preset_class.preset_xml_map)
File “/usr/share/blender/2.62/scripts/modules/rna_xml.py”, line 337, in xml_file_run
xml_nodes = xml.dom.minidom.parse(filepath)
File “/usr/lib/python3.2/xml/dom/minidom.py”, line 1945, in parse
return expatbuilder.parse(file)
File “/usr/lib/python3.2/xml/dom/expatbuilder.py”, line 922, in parse
fp = open(file, ‘rb’)
IOError: [Errno 13] Permission denied: ‘/usr/share/blender/2.62/scripts/presets/interface_theme/cycles.xml’

location:<unknown location>:-1

I’m guessing that it’s not supposed to load it from there ? like in windows it has the /users/local/appdata/roaming/BlenderFoundation/Scripts/Addons/Presets/Interface_Theme/ or something like that. Maybe it should be in another location ?

This is what it says when I tried like you said:

[email protected]:/# chown -R /home/usr/share/blender/2.62/scripts/addons/
chown: missing operand after /home/usr/share/blender/2.62/scripts/addons/' Trychown --help’ for more information.

No worries this is what practically did it for me at last :

[email protected]:/# chown -R msm /usr/share/blender/2.62/scripts/presets/interface_theme

and now it loads the .xml nicely in the Blender/Theme/Presets

I got a little confussed about the name there :stuck_out_tongue:

Cheers !

Hi, missing operand is username:users, if your username is tommy >
chown -R tommy:users /home/usr/share/blender/2.62/scripts/addons/
But it is much easier to work with a zip version of blender.
Download the latest blender, unpack where you want and work without struggle with user rights.
You could have different versions of blender on your system, I use often 3-4 versions of blender.
All settings are in /home/username/.blender. The folder is hidden.
If you create a folder “config” in /2.62 it is possible to use different settings for each version.
The error

IOError: [Errno 13] Permission denied:

is a rights problem, may the script try to write in this folder.

Cheers, mib.

Yes you’re right but I’m currently using a PPA to auto-update the blender from the latest SVN so I don’t have to install over and over again.
I didn’t know that it is possible to use zip versions of blender in Linux. i thought that was possible only in windows. I still have a few things to learn I see :P. Thanks for your input. Much appreciated !
Cheers !