Copying Rotation Only

I seek to copy only the rotation of an ik bone from one point in the animation, to the same bone in another point in the same animation. I do not want the position copied. How can this be done?

I tried to do it with the “Copy Attributes:” addon. But when I used it to copy the ikHeelRignt’s rotation, and then attempt to paste the copied rotation to this same bone, the rotation is not pasted, instead the ikWristLeft bone’s position (not its rotation) changed. It appears this addon can do only what it is meant to do, and this copy rotations from one object to another.

Let’s call those bones IK and IKCopy. IKCopy copies the world space rotation of IK. (This is, if IK points in the world’s +X, IKCopy will point in the world’s +X, regardless of the orientation of any parents of the two bones.)

Give IKCopy a Copy Rotation bone constraint. Set the target to the armature containing IK, and then set the bone target to IK. Other settings at their defaults are already correct for this situation.

If you want this to only be for this very instant, rather than a continual thing, apply a visual transform on IKCopy and then delete or mute the constraint. One way to do this is to hit the X button to the right of the influence slider on the bone constraint. (Which essentially mutes the constraint, rather than deleting it. This is important because even muted constraints create dependencies-- you cannot copy rotation at some future point from IKCopy onto IK without actually deleting the constraint.)

I am not trying to copy a rotation from one ik bone, to another. I need to copy a rotation from an ik bone at a specific frame in the animation, to the same ik bone at another frame in the animation.

Oh, pardon me. In that case, the easiest thing to do is copy/paste transforms, and then just delete the location keyframes:

  1. Go to the frame you want to copy from. Select your bone in 3D viewport, and ctrl-c.

  2. Go to the frame you want to copy to. Ctrl-v paste. Register keyframe.

  3. In graph editor viewport, lock your rotation channels (on the left margin). Select this frame’s keyframes, perhaps with ctrl k (select all->on current frame.) Delete.