Correctly adding models.

basically, I’m helping with an indie game and it’s my job to design levels. (which is fine)
the problem is i can’t remember for the life of me how to link / append models. I’m trying to move a model, like a house, into an environment or scene.

the problem is i can’t move the models once i get them into the current scene i’m working on. the outline shows up green. did i miss a step or am i linking/appending the wrong thing? (i’v been trying both since i can’t remember which to choose)

I believe that it’s best to Append them, since that essentially creates a whole new model in your new .Blend. Conversely, Linking the models limits your control over them, as they’re still just calling back on the original file (like, for instance, iTunes looking to your hard drive and calling on a .MP3 there). This means that you can’t alter the model itself (although you can scale and rotate them still, I believe).

To achieve this, you just go File (top left tab) > Append. There are also several tutorials on YouTube, if you search there.

thank you for your reply.
But appending it is where i run into the problem. the object takes on a green outline instead of the natural orange and become immovable in my work space. no rotating, sizing, or moving. i’ll take a few searches around again. maybe i’m just missing something incredibly obvious… :s

sorry i can’t be more helpful by uploading a screenshot. i’m blending on one computer and browsing on another. (internet issue)

No matter how many times i append the object i cannot move, edit, or change the object. I’v been searching around and i still can’t find a solution. i could really use some help guys.

You can create a proxy object, this page should help…

http://www.blender.org/development/release-logs/blender-243/proxy-objects/

The green outline means it’s been linked, not appended. When you do File -> Append, make sure the Link box is unchecked.

I promise it is.
Look





(imgur scaled down the screens so they might be a bit hard to see)

No, a green outline means it’s grouped, if you link/append an object that is not grouped it will show an orange outline.

Which version are you using? I just tried to do some linking and appending with a newer build I’ve been using from graphicall and I ran into the same problems. When I switched back to the version from blender org, everything was fine. Don’t know the reason for it not working like that.

thank you so much! after going into the guys original blend file i was able to separate the object from who knows what re-save and now i can move it. thanks again! i can’t tell you how much this helps.

Had the same thing happening. Dont know what happened. But I loaded factory settings and fixed it.