Corrupted blend file recovery


I have a fairly simple blend file which was mostly a Video sequence editor project. This and the blend1 and blend2 files now say ‘Failed to read Blend file, ‘<my filename and path goes here>’ incomplete’

I can’t append from it either. No other files appear to be corrupt in anyway, and I certainly didn’t get any warnings at the time.

Does anyone know if it’s possible to look at the blend file in a text editor or other application to attempt to fix the blend file? The filesize still looks about right if i remember correctly, so possibly it is possible to retrieve this in some way?

here is the blend file
Kerb.blend (1020 KB)

I don’t really want to have to get in the habit of once saving a file, opening it again just to check it hasn’t corrupted.

Thanks in advance, it is most puzzling! :spin:


I tried and I failed at every attempt.


well I appreciate you giving it a go Paolo! :slight_smile:

I just had the same issue. Scared the crap out of me as I’ve been working on something and then I couldn’t open the file anymore. When I tried it would crash blender. I was using 2.69 RE2 and I think it was to blame. I did manage to open my file though by using 2.68a

Was that the same for the blend1 and blend2 etc files? Glad you managed to get yours back, unfortunately i have just been using the official 2.68a with this file (I probably should have mentioned that earlier). Tried to open in 2.67b but no luck.

I suspect that possibly something has gone awry with the drive i was working from after all (i’m on windows 7/8 too). I just came across a couple of png files that seem to be a problem too. I’m currently running a diagnostic on it and will let y’all know what happens.

I opened the file using the Hex editor plugin for notepad++ to see if anything looked obvious, kind of like the guy who opens the bonnet to his broken down car hoping to find some obviously disconnected cables that once reconnected everything all works splendidly!

No such luck for me though. It’s a 4 hour job to get back to where i was if the diagnostics tools dont work on the drive is all. :frowning:

At that point, as there’s another user that experienced the same blend corruption, i suggest you to report this and the blend to the bug tracker.

In case this file corruption is an effect of whatever code fixes/changes that could have happened since 2.68 , maybe the devs have tools to check what went wrong in this blend file integrity and see if it’s coming from your system or from something in Blender

did you try to append objects to another file too?

if it does not work you should also report it

happy bl

Thanks for the suggestion, i’ll get on it once the diagnostics have completed. :slight_smile:

Ricky, I did try appending but the same error comes up, i’ll be sure to put that in the bug report once the diagnostic has completed. :slight_smile:

have finished the diagnostics and was unable to retrieve the file. In any case i’ve logged a bug here… on the off chance there is something unusual lurking somewhere. Obviously the devs will have a much better idea from looking at the blend file if it’s a likely Blender issue or just a corrupted file due to the operating system or hardware.