Cotton like material help

Hi everyone. I’m working on my entry for the blenderguru christmas contest, and I’m trying to make that puffy edge that’s on santa claus hats and coats etc. I did this by distorting a sphere slightly and using the fresnel value to fade the edges (I’m currently using cycles for this project). I then use this as a particle object that runs along the length of the material. It looks fine, but I’m getting this weird black edge:


I’ve disabled shadow casting in the source object’s ray visibility, but my guess is that this setting does not carry over to particles, as it is a setting applied to the actual object. Do you think that’s what’s causing the problem, and if so, is there a way I can disable shadows using materials rather than with the ray visibility settings? Or alternatively, if someone has another solution, I’d love to hear that as well.
Thanks!

If you have smooth shading on, see if it goes away if you change from smooth shading to flat. You might also check the normals of the faces.

Hm, the normals are correct, and flipping them doesn’t work. Changing from flat to smooth doesn’t change anything either. I’m pretty sure now that the problem is that the particles are overlapping. Removing the fresnel and simply mixing a transparent with a diffuse seems to work, but then I don’t get that great soft edge. Also, using a full transparent shader makes the particles completely black, which is strange.

Alright, I decided to go in a different direction and use hair instead of spheres. For some reason, I got the same result!


This is the hair with a completely transparent shader, but my goal was to have it fade off towards the tip. Could this be a bug of some kind?

Your transparent bounce value may be too low, using transparency with a high-density particle system requires high values.

Brilliant! That completely fixed it! Thanks very much!