Could really use some help with a project i have for 3D printing.

So I made this model, applied a thickness modifier of 2mm, applied it and exported it as an STI. I sent it to be 3D printed but got this message back:

Hello ________,

I have reviewed your print, and in its current state it is unprintable. This is due to sections of your print being extremely thin (0.07mm which is bellow the smallest possible layer height) This causes issues as this is thinner than my nozzle diameter (0.5mm). Furthermore, because the part is very complicated it will require a lot of support structures, and thus some surfaces will be more rough. However since they are so thin, they cannot even be printed on supports.

I am not able at this time to accept the order, however if you upload a revised model with thicker walls (At least 1mm preferably more) then ill have another look and give you an update.

I checked over the model on blender to see where it was so thin, but I am pretty confident that the solidify modifier worked ok.

Would anybody be willing to spare a moment to have a look at this and have a bash at fixing it? I haven’t used blender in a long while, but I thought I would have a go at printing something for my car (its going to be a clock and ipod holder where the radio used to be.

The blend file is here if anyone can spare the time to have a bash at it:

Thanks in advance.

check to see if there’s anywhere where the inner walls might have crossed over each other
(edit) I looked at the file, and there is no thickness at all. are you sure that’s the right file?
(edit) there were some other issues, that I fixed with apply scale ( ctrl A ) recalculate normal outside ( ctrl N ) and triangulate ( ctrl T )

Not sure how this happens, all the faces are pretty flat and the whole model is quite boxxy.

(edit) I looked at the file, and there is no thickness at all. are you sure that’s the right file?

Yes, I just removed the solidify modifier.

when I checked it with the solidify modifier on, there were a couple places where mesh was poking through. Triangulating the mesh fixed it.