CPU for display, GPU render lagging

I recently switched my display to the onboard vga video, and am using a GTX 780 FOR cycles rendering only. It works well and when it’s rendering I can use my computer, but I have a few scenes with a super large number of particles. These scenes are now quite sluggish in the viewport and are doing the old ‘not responding’ for a few seconds here and there. Any ideas on some settings I can tweak? My specs are in my signature (Windows 8 pro), let me know if you want any specific info. All ideas appreciated!

Hi, Blender viewport performance is bad for high poly, particles and so forth.
Default setting in Particle > Display is 100%, reduce it to 50 or less to get some performance back.

Cheers, mib

Ok thanks.