CPU + GPU Rendering not working (OpenCL)

I’m new to Blender and wanted to check, if my PC Build is capable of rendering. For that I’ve downloaded the ‘Spring’ Demo File from the official Blender page.

First I’ve tried rendering an image with my Intel CPU which worked alright. Then I’ve checked the checkbox for my AMD GPU for OpenCL in the Preferences and tried ‘GPU Compute’ Rendering which also worked but was way slower.

Since I saw some videos on YT I knew that you can also render with CPU and GPU at the same time. So I’ve checked both my CPU and GPU for OpenCL in the Preferences and tried ‘GPU Compute’, which was kind of disappointing. For some reason only my CPU is used, but not my GPU. Since I’m using Linux, I thought it was a Problem with the OS, but on Windows the same thing happens.

Those are some details that may help you to solve my problem:

Specs / Software:

Intel i5-6500 3.3 Ghz 4 Core/Threads

AMD MSI RX 560 Aero Itx 4 GB

16 GB RAM DDR4 2133 mhz

Mushkin SOURCE 500 GB

Dualboot – Manjaro / Windows 10

Blender v2.83.1

The GPU is officially supported (GCN 4) (https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html#amd)

The GPU supports OpenCL 2.0

My question are…

  • Is CPU + GPU Rendering only supported by CUDA?

  • If not, what am I missing here?

First it is definitely supported in OpenCL (last tested on 2.82, will test on latest and report back if feature is broken)

I have AMD Threadripper CPU and AMD Vega GPUs’ so can only test this config.

Just tested with 2.83.1. GPU and CPU rendeirng works as regular.

One thing to note about AMD GPU’s is the time for “kernel complie” , which might look like it isn’t working. had to wait 20+ seconds for the kernel to compile after i changed the gpu + CPU setting.

Additinoally what application did you use to track GPU usage?

WIndows by “default” does NOT show usage, as it categorizes the usage as “compute” rather then 3D tracking which is on by default. you can manual change to “compute 1” in windows task manager (though sometimes that is compute 0… and compute 3 for me… no idea why it changes.

Best to use GPU-Z to verify usage…

First of all thank you for your quick and efficient answer. :slight_smile:

I’ve sadly made a mistake, which I’ve noticed when you mentioned that I should try to track my GPU usage.

I assumed that my GPU is not used, do to the fact that Blender only shows four squares while rendering, which is similar to when I only use my CPU.

But I’ve tracked now CPU and GPU and both of them are used while rendering.
CPU

GPU

Still I don’t understand why there are only four squares. Shouldn’t it be more? At least in video I’ve saw someone said that it would show one for each CPU core and one for the GPU.

Will admit your current isue with missing tile is beyond me.

I only had “similar” issue when i sometimes started blender. And my default GPU selection when i first rendered was ignored. had to go into preferences/system, uncheck and check the GPU then save profile again and then it worked.

But you have somethign different, as GPU is running, CPU is running…

Try chaning tile settings, or CPU core utilization in blender to see if tile counts change correctly. Could be a bug

Hi again.
I’ve tried decreasing and increasing the tile size, but it still just shows 4 squares.
The only thing I found was increasing Threads to 5, which then showed 5 squares, but I think that is not what you mean by CPU Core utilization. Sorry for being a noob, but where can I find the settings you’ve mentioned?

But something interesting is that if I render with CPU only it takes arround 50 min, but when I activate CPU + GPU Rendering it takes around 30 min, even though it only shows four squares. So I’m not quit sure, but did Blender maybe changed in newer versions the appearance for the CPU+GPU rendering?