Crackling sound on VSE when fading in

Hi guys

I’m animating a sound strip volume to perform a fade in, but the fade in gets crackling while animating.

The problem persists even after rendering the strips to a mpeg video file.

Please, can anyone shed some light on this issue?

How can I get rid from those crackling noises?

Try packing the audio from the properties tab in the VSE? Try clicking the refresh Sequencer button at the bottom of the VSE. Also check the audio bit rate is large enough to accommodate file.

It’s a strange issue, I haven’t heard of it before. Can you recreate the bug with another .blernd and a different audio file?

I suspect audio clipping issues.
What’s the source audio format? Sampling rate? Bit rate?
Low sampling and bit rates will almost certainly result in audio clipping esp if the curve is too steep.
Convert the src audio to wav and give it another shot.
You could also check the steepness of the animation curve in the graph editor. Is it a straight line extending from the one keyframe to the other? A somewhat curved line?

Hi David,
I didn’t pack the audio yet. I’ll try it ASAP.
Unfortunately, clicking Refresh Sequencer didn’t help. :
I don’t know if I can recreate the issue, but I can try it too.

Hello Blendercomp,
Hummm wav format… sure I’ll give it a shot!

Here the audio format info:
Length: 145 seconds
MPEG-1 layer 3
128 kbps, 5577 frames
44100 Hz Stereo

Here is a screenshot from the audio strip and the volume interpolation curve.
The interpolation takes around 500ms to change the volume from 0 to 1.s


Thanks in advance guys!

Well there is nothing wrong with that curve, so the rate of slope change is eliminated as probable cause.

Have you tried using the uncompressed audio (with or without packing it)?

When you play back the audio in realtime in the sequencer do you also get this crankling effect?
How about testing it outside of blender with a media player? Get any of these distortions?

Which sound system are you using? SDL or OpenAL? Also, what’s your OS and blender version?

Hi Blendercomp,

Please guys, sorry about my delay to post again!

I tried all options, but the crackeling still is there.

I’ve noticed that when I change the Mixing Buffer down, under sound options in the user preference the sound gets worst, but it doesn’t change the output render anyways.

I’m sending the link below with the wav I’ve used so you guys can try it if you want.

http://www.4shared.com/music/RynAQJpj/Crackeling.html

*I’ve put the fade in right in the beginning of this sound.

Neviton
I wanted to give it a go on my system but you cannot possibly expect me to register with an unknown (to me at least) filesharing service just to download an 800 KB mp3 file! This is unacceptable.
Please use a decent filesharing service that doesn’t require registration.

Ok I am at work behind expensive firewall and good antivirus so i will have a look.

Hmmm, I downloaded a wav that was PCM S16 LE (araw). Played in Itunes fine and VLC fine. But Blender crackled when playing and after cacheing it. And yes it is much worse when performing animation like a curve fade. I’m guessing it is an issue with ffmpeg and it’s ability to decompress that codec. I think that you need to transcode any of those files to something more Blender friendly. I have no suggestions though as I haven’t experienced this before.
Can I suggest that you try and submit this as a bug on the tracker? http://projects.blender.org/tracker/?group_id=9&atid=498

Hey it looks like MpegStreamclip http://www.squared5.com/ will play the file and convert it. You just have to tell it to import it even though it doesnt recognise the file type. You can do batch conversions in this way too.

Hi Blendercomp,

I’m surprised to know what you think about 4shared.
Actually I thought it was one of the most know file share sites.
So sorry about it.

Here is a new link:
https://docs.google.com/file/d/0B2a-l-2TFjg5c3NMMDRja1BDeE0/edit?usp=sharing

Thanks a lot for you time 3pointEdit.

I’ll wait for the Blendercomp replay before thing about submit a bug, trying to avoid any false negative.

:wink:

I worked around this very problem by exporting just the .wma then rendering the video seperately. then I combined them in a different program.
the .wma exported didnt have the issue.

There’s no need to apologize, no harm done. But you have to accept that if you want others to help you, you shouldn’t make it hard for them to do so. In this case, I wouldn’t bother registering with a filesharing service just to download an 800 KB file. That’s a matter of general principle! :slight_smile:

On topic, I cannot replicate the error you get on my linux box (64bit Kubuntu) running the latest trunk compiled minutes ago (r54306).
I should note that crackling does appear both on the sequencer and in the video file produced only when the increase of the volume is substantial, say from 0.10 (practically inaudible) to 5. But given the nature of your audio (what is it really?) that doesn’t surprise me as it simply amplifies the existing frequencies by a factor of 5.
On the other hand, if the increase is from 0 to 1 (as in your example) everything is normal when playing back the animated volume increase in the sequencer and also in the rendered video file (see attached screenshot).


The rendered video file is also attached for you to check.
Hope this helps.

Attachments

crackling_video.avi.zip (1.91 MB)

I found random crackling without altering levels, just playing the file back! On 32bit win box. I performed a 0.0 - 1.0 fade and it crackled all the way. b2.65 r53973

Oh? Interesting! Then Blender’s probably got nothing to do with it! :slight_smile:

On 32bit win box. I performed a 0.0 - 1.0 fade and it crackled all the way. b2.65 r53973

could you please check the rendered video file attached to my former post? Do you get crackling when playing that back?
Considering that the source audio is pcm I didn’t think that I needed to do any transforms. Raw audio is as good as it gets.
I wouldn’t expect it to crackle when going from 0 to 1 and I confirm that this is what happens on my system. Going over 1 however, will almost immediately lead to clipping at least for the first 1.5’’ of the audio.

Moreover, if you import the video file in the VSE on your system, and try to repeat the audio fade, do you still get distortions?
Just wondering…

Same with your vid file. I tried all the User prefs for audio, still crackles on playback. Even after packing the audio. Only occurs on the dramatic fade up at the start. And it is variable to, not allways at the same place.

Do you get crackling when playing back the video using VLC or any other media player?
Moreover, which sound system are you using in Blender, SDL or OpenAL?

Tried all audio settings and as before other players are fine.