Crash during any type of render step

Updated to the latest NVIDIA driver for my system (R331.65) and now blender is crashing periodically. Generally when it tries to render something, but not always. I’ve had it happen when I change an Image Texture Node. When hitting F12 to render, and when trying to select the render option for a 3D view.

I have tried lowering all of the cycles settings, raising them, etc. Also tried switching between CPU and GPU rendering, also disabling the GPU support in user prefs.

Is there a way to spit debug output or anything from blender to hunt down where the issue is?

Also it will occasionally run just fine for a few min and then crash.

GeForce GTX 660M
Intel Core i7-3610QM CPU @ 2.3GHz
8.00 GB RAM
Driver: 331.65
Windows 7 Home Premium

This ended up due to one of my normal map textures, it was large (~20MB) and in bmp format. I resaved it as png and haven’t had any issues.

Awaiting blender’s transition to git, at which point I may get ambitious and build my own debug copy to hunt down why it crashed on the bitmap. And if anyone tries to tell me “that’s just what happens when you use large textures” I will punch them in the face. There are right and WRONG ways to do memory management and error handling. Allowing your software to crash as a result of a large file or corrupt input is not acceptable for the level of application that Blender has become.

You could try running Blender from the command line using the -d switch. Really, though, the best option would be to run Blender through a debugger. In the Linux world, we’d do it with something like gdb. Not sure what you’d use in Windows? Visual Studio?

So In an effort to solve the issue assuming it was the driver that caused it. I downgraded to the Previous driver version (327.23). Still no dice. So I’m left to assume that it’s something in my blend file(?). Not sure where to go without a full dev environment setup.

So this is all I get (just -d no debugger)


C:\Program Files\Blender Foundation\Blender>blender.exe -d
Blender 2.69 (sub 0)
Build: 2013-10-30 16:56:38 Windows:64bit Release
argv[0] = blender.exe
argv[1] = -d


Note: No (valid) 'C:\Users\s7726\AppData\Roaming\Blender Foundation\Blender\2.69
\config\startup.blend' found, fall back to built-in default.


read file
  Version 267 sub 1 svn r0


ordered
 OBCube
 OBLamp
 OBCamera
read file C:\Users\s7726\AppData\Roaming\Blender Foundation\Blender\2.69\config\
userpref.blend
  Version 269 sub 0 svn r0
Read new prefs: C:\Users\s7726\AppData\Roaming\Blender Foundation\Blender\2.69\c
onfig\userpref.blend
found bundled python: C:\Program Files\Blender Foundation\Blender\2.69\python
read file
  Version 262 sub 3 svn r0
read file
  Version 268 sub 5 svn r0
recalcob Cube
recalcdata Cube
read blend: C:\Users\s7726\Google Drive\Wedding\House Model\house.blend
read file C:\Users\s7726\Google Drive\Wedding\House Model\house.blend
  Version 269 sub 0 svn r0


ordered
 OBCube.007
 OBArea
 OBCube.006
 OBCube.005
 OBCube.004
 OBCube.003
 OBCube.002
 OBPlane
 OBCube.001
 OBTorus
 OBCube
 OBCamera
recalcob Cube.007
recalcdata Cube.007
recalcob Cube.006
recalcdata Cube.006
recalcob Cube.005
recalcdata Cube.005
recalcob Cube.004
recalcdata Cube.004
recalcob Cube.003
recalcdata Cube.003
recalcob Cube.002
recalcdata Cube.002
recalcob Plane
recalcdata Plane
recalcob Cube.001
recalcdata Cube.001
recalcob Torus
recalcdata Torus
recalcob Cube
recalcdata Cube
Evaluate all animation - 0.000000
        No Actions, so no animation needs to be evaluated...


This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.


C:\Program Files\Blender Foundation\Blender>

This time though it did actually perform a F12 render, but then when I tried to set one of the 3D views to Render it crashed.

Can you get it to crash on the default scene?

Nope.

It doesn’t seem to want to crash with the default scene. Is there a good route to systematically remove things from my scene (saved copy of course) to try and narrow it down?

Heh… one at a time. :slight_smile:

Quick additional question… is this using Blender Internal or Cycles?

Hi, sometimes the .blend fie is corrupt and it is better to append objects in a new file.
Make groups and append the groups then.

Cheers, mib.

Cycles.

So I’ve got another puzzle piece for this one:

If I load up the default scene, switch to cycles, and then render it a few times, load up my blend, and either render or set a view to render mode, it will render once (1 time). Then anything that would cause that render to change, causes blender to crash. Including trying to add a texture coordinate node.

Are you using GPU for rendering? Assuming you are, does the crashing go away when rendering via CPU?

Yes, and No. It crashes under either method.

More info:

I moved the file and it lost all of the textures. But it renders. So I’ve been going through and adding them back in.

I’ve found that when I add the normal map for one of my textures, it ends up crashing when I render. I’m using bitmaps and the file is 23M, could that be the issue?

Can blender just not handle large textures? Is there another format I should be using? The other textures are a mix of bmp, jpg, and png.

So since removing the one normal texture, resaving it as a png, and readding it. I’ve been going strong all day with no problems.

It would be nice to see an error or something if a texture was either too big, or corrupted in some way.

Also the process of “finding” missing textures could use some work.