Create primitive object of a known size

I’ve spent 4 hours trying to work out how to change the size of an inserted cylinder. (the fact that it isn’t immediately obvious how to do it should have been warning enough.)

I searched the web and found this thread from 14 years ago asking the exact same question:

The three solutions offered there – 1) perform weird math; 2) create your own primitives; 3) modify the source and re-compile the program; – do not exactly appeal to a me as a new user.

So, it still the case 14 years on (2.79) that there is no simple way of saying that I want a 500mm diameter x 1mm thick cylinder?

I’m not sure I understand your question, admittedly I’m using 2.82a. Here’s the screen when you add a cylinder:

SImply entering the desired values into the dialog will alter the cylinder to the parameters desired. IOW, the cylinder is “live” until you hit ENTER or click on the screen. If you don’t see the dialog immediately, hit F9 to invoke it. (But, you should.)

If you enter very large numbers you may run out of clipping distance, so beware of that. Clipping is set in the VIEW tab of the “N” panel.

Thanks.

I never even saw that dialog as I run with al the screen ornamentation turned off. I was moving the default cylinder into the right place before attempting to size it. And by the time I went looking at the T panel, the dialog is gone, apparently never to return.

What a horrible way of working :frowning: Blender is sooo powerful, but the interface…like trying to ride a Ninja H2R using reins and stirrups.

Maybe don’t do that.

Maybe don’t do that.

With the standard layout, of my 1920 x 1080 screen over 40% is given over to controls; 80% of which I have no use for at all, and of the remaining 20%, 15% I might need once or twice per session for brief moments.

I’m used to interfaces that, when there is information – or the opportunity to supply some information – pertinent to the current operation; the dialog containing it pops up or otherwise makes itself known.

So far, the only parts of the screen chrome I’ve found a use for are those areas in outlined in green – and now I know that the bit outlined orange has occasional, transient, useful content.


If I could make it look like this:

I would. But that does not seem to be possible.

My every attempt to rid myself of those interface elements I have no use for, results in duplicate of the bits I am trying to get shot of.

This is what I’m used to, very simple, very usable:


I’m not advocating the above program, just showing what I’m used to. I appreciate that I am probably not a “typical” blender user.The difference between engineer and artist I guess.

I really want – actually need – to get used to Blender, but damn it is hard going.

I suggest you upgrade to 2.8n.

BTW, what s/w is being used there?

BTW, what s/w is being used there?

DesignSpark Mechanical which is a free(ish) – but highly hamstrung – version of SpaceClaim. It is a very usable, very intuitive, easy to learn and really quite powerful CAD program, but they’ve stripped out most of the export formats and want something like $500 to allow you to export an assembly in a format that allows it to be worked on in other software.

If you’ve got 15 minutes, take a look at this youtube video. I was spellbound the first time I watched it; but like all software, watching an expert run through a well-rehearsed script is deceptive. That’s not to say that what he does isn’t pretty much exactly as easy as it looks; only that it only goes so far. Trying to model anything that is not rectilinear or round suddenly exposes the limitations. I tried to model a simple spoon – nothing photorealistic mind, just smooth curves without ugly joins between the curved and flat sections – and came up short. (I’m also quite certain that it has been sped up about 5x,)

I have no installed v2.82 – or rather downloaded and unpacked; the latest version in the Synaptic package manager – and I get your point. I was unaware that the interface changes were quite so dramatic. Thank you for prompting me to look. It is certainly closer to what I’m used to; at first sight. I’ll hold off on saying more than that once I’ve tried using it in earnest.

I hear you there. Fer shure.

Cylinders: It’s not properly procedural, you get ONE chance (plus undoes, of course) to set the division level to your liking, but it’s better than nothing.

As long as you’re still in research mode, check out the youtube vids that have ‘procedural modeling’ in the title/description, some Blender users have done remarkable things with truly procedural blends. Generally, they require a good acquaintance with Modifiers and a good imagination of how to use them in non-intuitive ways.

I also recommend Grant Abbitt on YT, as he consistently drops gems in most of his videos that have me smacking my forehead.

OH, and for a more CAD-like experience, FREE, I recommend Fusion360.

This may help:

https://docs.blender.org/manual/en/latest/interface/window_system/areas.html#areas

‘procedural modeling’

I didn’t know what that was – as a retired programmer ‘procedural language’ has meaning – but this is quite different. Indeed, whether it is the ‘Blender community’ at large, or maybe the CG industry, or just individual Blender(er?)s, many of the videos and tutorials use familiar terms in unfamiliar ways.

But I get the idea, rather than artistically sculpting things until “they look right”, you start with a primitive shape and apply mathematical modifiers to hone it to your target. Seems even less direct* than blender ‘normal’ way of working (if there is such a thing).

DSM/SpaceClaim are termed ‘Direct modellers’; which may or may not be a part of your lexicon.

Re: Grant Abbitt. Very pleasant manner and nice, economical presentation style devoid of too many ums and ahs, pointless hyperbole, or needless repetition. But … you knew there was one coming right :slight_smile: … whenever I hear someone say “till it looks about right”, I stop and move on.

Essentially, the stuff I’m hoping to use Blender for are (potentially) real-world mechanical mechanisms, not artistic* endeavours. I need to produce accurate models that can be used to perform FEA mechanical analysis. The parts of Blender that hold particular attraction to me are:

(*just as well as I don’t have an artistic bone in my body!)

  • Exquisite control of the mesh. (One of the biggest problems with FEA is waiting hours for it to mesh the model only to find out that it has a bunch of bad normals or other geometry problems.)
  • XYZ Math Surface for the generation of complex components (Gears, springs coils, threads).
  • Scriptability to accommodate changes to the above.
  • The physics engine for first pass analysis of mechanism motion before exporting to expensive (time/money) FEA analysis.
  • The ability to animate and record the motion analysis.

Photorealism, UV texturing et al. are of little concern. Fascinating, but unnecessary for my purposes. (One of the reasons I’ve previously been avoiding Blender (besides the old UI) is that I fear I might get all caught up in the photorealism production process.

Is it the right thing for my purpose? I’m not yet sure; I’m still at the point of working out how to drive the thing.

BTW. I went to sign up for an account for Fusion360, and their website crashed my machine. FireFox 71 under Linux and no warning at all. Black screen and powered off. (I’ll try again later tonight.)

One question (that should probably be asked as a new thread, but: Do you know if it is possible to switch the functions of RMB and MMB in 2.8x? Ie. Use RMB for orbitting and MMB for context menus.

If it is, it is very well hidden. I’ve spent an inordinate amount of time blundering around in the preferences.

Many thanks for your time, Buk.

RE: Keymapping

Blenders keymap is very configurable!

That being said, it’s a bit like pulling teeth from a shark, there’s a lot of settings, and it’s pretty easy to break things. Also it sucks. I’ll come right out and say it:

Blender’s keymap editor sucks.

It can do what you want, but it is annoying to do so.

So, with the prologue out of the way, here’s how to go about swapping rmb for mmb:

[note that all of these screenshots are from blender 2.82, but they should generally apply to 2.79 as well]

First [red], in the keymap editor, change the search type from ‘Name’ to ‘Key-Binding’:


Next [orange], search for ‘right’ - this will show all controls using any button with ‘right’ in the title
Next [yellow], find the context menu option and click the triangle to expand it

Next [green], change the mouse button to middle mouse - note that this will make that option instantly disappear, since we are filtering by ‘right’ (no longer using the right mouse, no longer shows up in the filtered list)
Now[cyan], change the filter to ‘middle’
and finally[blue], repeat the process on all the middle mouse controls, changing the mouse button to ‘right’

Again, this process sucks. There are so many sub-contexts for every control, and having access to every single one of them does give a lot of flexibility in the way that the controls can be set up, at the great expense of that process being a pain in the ass.

1 Like

RE: Resizing objects

While blender is generally a destructive modeler, there are some things that can be changed after creation fairly easily, and thankfully dimensions are one of them.

For simply changing the size of something I use these options here:

Thank you for this extremely accurate summation.

In short: “You can probably do it, but you will HATE the process.”

It also didn’t work. The MMB stopped providing orbit/pan/etc.; but the RMB never gave up producing the context menu. I tried re-starting Blender after saving the changes; nada. And after re-starting the OS; nada.

I reset to factory defaults and the followed the process step-by-step ever so carefully; saved, re-started, re-booted; 3 more times. Still RMB produced the context menu.

Finally I tried reset to FD, and then only changing “Region context Menu” to be ‘mouse button 7’ (which I don’t have) with alt, shift and ctrl, and still RMB produces the context menu?

Could someone try changing their Region Context Menu to something else and see if they can get it to take?

--------------- off-topic below ------------

Also during one of the attempts, the keyboard locked up.

Not just Blender, but the entire OS forcing a power off to recover, but that seems more likely to be the distribution I chose (Zorin, on the basis of a web review that also recommended RoboLinux!) more than Blender.

Ie my problem not this forums…My next step: Blow away Zorin which has proven itself to be less that reliable and install something more well-known.

Currently considering Mint, Ubuntu and Manjaro. Recommendations welcomed if such off-topic advice is allowed here?

I don’t know if I’m looking in the ‘wrong place’, but this is what I see when I start a new session, A delete everything, shift-A Mesh->cylinder:

Neither in the “Add cylinder” dialog bottom left, nor the “Object properties” pane right does it show “Dimensions”?

My guess is that in your screen shot you either typed r dragged to “scale” the cylinder; and once done the “Dimensions” resulting from that scaling show up?

Which mean that to get a precisely sized cylinder I’d have to scale the default size by some known amount, then calculate how big the default cylinder is by dividing the resultant size by the known scale factor. Then blow it away and start over having calculated a new scale factor to get the size I want?

Please tell me there is a better way?

Also, while I’m asking.

I found the place in the Scene properties to change the units to mm rather than metres; but I have to do this every time I start a new model sorry, ‘scene’.

I have failed to find a preference to establish this as my default?

click this button to pull out that shelf:
image

or press ‘n’

Set your unit settings to what you want, then save the startup file:

Ugh, you are right, it is even worse than I thought. Search by name instead, and search for ‘context menu’

you will see that every single mode in every single editor has it’s own setting for context menu. I thought that region context menu was more generic than it is. I’m telling you… shark teeth.

Simply change all of these settings to get what you want: