Creating paper models

When i hit the unfold script i get the same message over and over “python error:check console” How do i fix this?

So, look in the console window and tell me what it says.

Thanks emu I’m using AO now and it works great!

That is what I get after clicking unfold, and after “Script error, check console” thing…

Samipe:: Thanks! It seems that this happens in the windows version only, so I didn’t notice it.

The solution is simple: install python. Official website is I don’t actually know why isn’t there a word about that on the download page :-/

Thanks to you too! :stuck_out_tongue:
This isn’t the only script what is whining to me, i just usually forget them. But now I really want this to work! :stuck_out_tongue:
EDIT: Still not working! I installed python, should it now just work with nothing, or do I have to activate it from Blender or something?

Samipe:: Still the same message and the same text in console? It should write “Checking for installed Python… got it!” in the beginning.
No, you don’t have to do anything more - AFAIK.
The other scripts don’t still work too?

The model was in .blend that i opened after install, it didn’t work. Now i tried with new file, and it works… O.o
Anyway, i can’t get it to work with anything more complicated than box, always failed at something about 50%… Even if the model is 100% sure to be possible to do that.

Hi, I made a python script for making paper models in Blender a while ago. It’s called B-paperizer. It contains a simple unfolder and an SVG exporter. You start with a UV-textured model, select the edges that should become the future cuts in the edit mode and press Unfold. The script is able to export textures to the svg file as well.

I can provide the script. I wanted to upload it, but the forum doesn’t allow for attaching .py files to the message.

Here’s the link for the script: It’s licensed under GNU GPL v.2. Basically, the license says that you can alter or use the source code to your liking, but all the works that will be derived from the licensed code will have to be released under GPL as well.

hi, i tired this but something wierd happens

when i try to unfold i get this error message in the console. i have python 2.5 installed

heer is the error:

Unfolding selected object
Using  __main__.RandomEdgeIterator
even: True  depth: 0
unfolding with overlap detection
100% unfolded
faces created: 6
faces visited: 6
originalfaces: 6
net avoided at least  0  overlaps  - A complete net.
Sorting out IPO
 added RotZ IPO curve
 added  RotZ
 added IPO source
Adding script link for animation
Traceback (most recent call last):
  File "<string>", line 1454, in buttonEvent
  File "<string>", line 1447, in unfold
  File "<string>", line 1368, in installScriptLink
SystemError: error return without exception set

does this mean anything to anyone?

Czestmyr:: wow, that looks interesting. That had to be a lot of work. I will try it soon (now I don’t have a computer good for blender).
BlendMaster:: oh wtf… I don’t understand that at all. It looks like you have the ‘anim’ button turned on, can’t it cause the problem?

emu - this is a great technique! I will look into how to make Unfolder do this automatically in a future version.

Ha! I love it! I’ve been making Nintendo Papercraft (check my blog) for a year now! I use a diffrent tecnique though… What I do is export the .blend as a .3ds and “unfold” it in Pepacura viewer. Pepakura does every thing automatically. You should really try it!


I tried your technic with a simple box with a roof. While unfolding it doesn’t preserve the
face area ratio - it squeezes the faces. :expressionless:

Any suggestions?

Semmelb: no… I can’t guess how can it happen. When I unfold a simple object you describe, the results are just fine:

If you really can’t solve it, please post a screenshot. If you find the problem, tell me - maybe I really missed something in the tutorial.

Thanks for your replay.

So I have done an screenshot with some checker texture.
As you can see the checkers on the object are not squared.
If you compare the areas of the face you can see it too.

Maybe I missed some options in the script?


You are right. I didn’t notice this, thanks.
Press Ctrl+A (in object mode) and everything should go fine when you unfold it again. The script is (stupidly? maybe) not caring about scale of the object.
You can also clear the scale (Alt+S in object mode) - that will not have exactly the results you want, but it is the way how the script sees your cube.

I hope it works now.
Come on, make some cool model! :wink:

//edit: I’ve just fixed it in the tutorial.

So, I think now it works. Great!
It generates a flate mesh with the right measures and the uvs are right, too.

Now I can create some more complex ones :wink:


Hello, I am running Blender with Fedora 7 Linux, and I have both Blender and Python installed, but Blender is unable to find Python. Here is what the terminal says when I open Blender:

# ./blender
guessing './blender' == '/home/karl/Desktop/blender/blender-2.45-linux-glibc236-py24-i386/./blender'
Compiled with Python version 2.4.1.
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
Checking for installed Python... No installed Python found.
Only built-in modules are available.  Some scripts may not run.
Continuing happily.
Saved session recovery to /tmp/quit.blend

Here is proof that Python is installed:

# yum install python
Setting up Install Process
Parsing package install arguments
Nothing to do

I even tried setting the path manually in Blender, but that did not work either. I am out of ideas! :frowning: Does anyone know what my problem is?

Ha! Never mind about that. I got it solved. All I had to do was update Blender! That problem has been driving me nuts for several weeks now, and the solution was so easy! Thanks anyway, though.