Creating runtime on linux?

When trying to save a test binary of a simple game (by using the save runtime entry in the file menu) I get this message: “unable to make runtime: unable to find runtime.”

On blender3d.org it says that “On Windows, Blender can save a project as .exe, on OSX as .app, and on Linux/Unix as a regular binary.”

Link to the page with the quote:

http://www.blender3d.org/cms/Blender_2_34.319.0.html

I was hoping that I would be able to make a binary for linux (which is the system I’m trying to make the binary on).

I’m running blender 2.34 btw.

Any ideas?

Cheers,

b01c

try running blender with the working directory being the same as the blender executable

but, first, there needs to be an executable: blenderplayer, in that folder
[if it is not there then without finding it you are a bit out of luck]

z3r0 d: Thanks for the reply.

I’ve copied the blenderplayer executable from 2.25 to the 2.34 directory. This gets rid of the error when I try to create the runtime.

However: Every time I try to run the executable I get a segmentation fault. I’ve tried this with several example files and the result is always the same.

Is there a blenderplayer executable for 2.34, or was I correct in using the one for 2.25?

Cheers,

b01c

Ok, well I just did a little research and answered my own question: I need the blenderplayer.exe for 2.34.

I’ve found out that it is included in blender 2.34 for windows (don’t know about OSX) but not for linux.

I find this a bit strange since the blender3d website explicitely states that you can create Linux/Unix executable binaries (as I stated in my first post).

Anyone have any more information on this??

Cheers,

b01c

I dont’ think you’re the first one to mention linux doesn’t have a blenderplayer

they are different for each version, so a 2.25 one will not work right [but I think you’d ought to be able to create an executable with it]

well anyway, someone posted a linux build of it
or, at least that is what I thought

you really should have searched [for blenderplayer and linux], there are a bunch of threads, like [I haven’t read these]
http://www.elysiun.com/forum/viewtopic.php?t=28873&highlight=linux+blenderplayer
http://www.elysiun.com/forum/viewtopic.php?t=28698&highlight=linux+blenderplayer
http://www.elysiun.com/forum/viewtopic.php?t=24317&highlight=linux+blenderplayer
http://www.elysiun.com/forum/viewtopic.php?t=19074&highlight=linux+blenderplayer
http://www.elysiun.com/forum/viewtopic.php?t=7139&highlight=linux+blenderplayer

z3r0 d: Thanks for the info.

Cheers,

b01c

U have to read other post’s (forum monkey, lol) %|

I’ve build a blenderplayer for blender 2.34.

http://planeta.terra.com.br/informatica/projetomo/blenderplayer.tar.bz2

Copy and paste the link.

THANKYOU!!!

Cheers,

b01c

Hello - I have tried to use your blenderplayer binary to build a standalone player, but I get this error:
“error while loading shared libraries: libpython2.3.so.1.0: cannot open shared object file: No such file or directory”
when I run the final game binary or when I just do a ./blenderplayer on the CL.

Any word?

This may not be the most stable solution, but this new cvs linux build contains a functioning blenderplayer:
http://www.blender.org/modules.php?op=modload&name=phpBB2&file=viewtopic&t=4666