[CRTL+B] Asymmetrical Bevel Tool

Hello. I have this problem and after hours of searching for a solution I’m posting a thread here. I’m trying to round the edges of this shape.
When I select the outer edges and try to use the bevel tool it doesn’t do it symmetrical.


When I try to bevel one edge at a time it kinda works, but that makes it hard to bevel the top.


Is there something I can do? Or is there something wrong with the mesh? I hope someone with more Blender experience than me can help. I attached the blend file on this post.

Attachments

BevelTest.blend (550 KB)

Apply the Scale with Strg+A. This should do it…

Thanks for the answer, but unfortunately it doesn’t work.


Your mesh has triangles and ngons that stop the bevels from continuing. You need a quad mesh with continuous edges to get a bevel. Do a search for ‘topology’ and you can find lots of guidance on this topic. I messed around with it a bit and found it to be a challenging shape.


Wow, that looks gorgeous. I’ll definitely extend my knowledge on topology now. Thank you very much!

Oopion33: In recent builds of Blender (after July 5, 2015), there is a ‘loop slide’ option that is on by default. Turning that off will make the bevel widths more even in the example you are showing, I think.