crummy looking object in animation?

I have an animation that was rendered with blender internal engine.
I have uploaded it to the link below.
I think you will notice the problem right away but if you don’t.
My lamp objects base is very flickery and my button object on the floor is as well.
How can i fix this.
Ps. Have recalculated normals on all of these.
http://www.freefilehosting.org/public/17613/recallampanpart2.mov

File may take a bit to load but it is only 1.4Mb

Looks like 'Z-fighting’to me, chck to see whether you have a duplicate lamp base mesh inside one another. (go into edit mode and select the linked vertices with L and delete the extra one)

Also, turn on anti-aliasing, it helps reduce the jaggies.

And lastly, the animation reminds me of that Pixar movie.

he artifact could also be caused by shadows.  Turn off shadow under the render panel(temporaryly) and see if that fixes the problem.

Thanks for the info I’ll give it a try.
Yeah it looks a lot like pixar’s lamp and thats what i was going for.
I would never use it but just for kicks and learning purposes only really.
But that erks my butt it took this thing 20hrs to render and it looks like that.
I guess next time i’ll do a small preview render before the actual thing.

Twenty hours rendering for three seconds of video with OSA turned off??? :eek: What OS and machine are you using?

What are your Blender settings? I assume you ray-traced it, though it would appear unnecessary for this scene. Are the models very high poly?

Definitely turn OSA on for final renders but be warned - if it took 20 hours without it, you better plan a few days away from Blender to render with OSA on! Without OSA though, you’ll get hard edged shadows that can appear to flicker. It’s hard to say if that’s the problem here since the resolution is low. Xiaxuele’s suggestion is also a definite possibility.

(As a rough guide, my 55 second SuperWuMan animation takes less than four hours to render with OSA=5, on a G4 1.25GHz Mac. It doesn’t use halos but it’s a slightly more complex scene than you have here. I don’t use ray-tracing)

No I have Reopend the project and OSA was on and set to 16. Yes Ray trace was on.
I have also found out that my every peics of lamp, floor, and button are set to ray mirror.
I’m using a G5 Mac 1.6 Ghz 1.25 Gb ram.

I looked up the z-offs but i didn’t help.
I was trying to upload the .blend file but i haven’t had any louck with a file host that will take it yet.

Ok i found one.
http://dl3.ohshare.com/v/2009742/Lamp.blend.html
AndyD I love your animation that is so cool.

Thanks :slight_smile:

Okay, a number of “issues”

1: Your lamps are not set for raytraced shadows so you can turn off the raytrace button and save LOTS of render time. Turn off EnvMap too since you’re not using an Environment Map (I think).

2: You have an entire farm of lamps sitting below the main scene. If these are on a hidden layer at render time that’s okay but if that layer is “on” then they will influence render time for no apparent benefit.

3: You’ve used “Set Smooth” on simple cylinders. This isn’t good enough and is causing the flicker problem. “Set Smooth” is an illusion - it doesn’t really smooth anything. You can turn on auto-smooth and set to 80 degrees for a better result but seriously, the best solution is to add geometry to the cylinder edges then apply a subsurf modifier then Set Smooth to truly smooth them out.

4: Turn OSA down to 5 for testing renders. Increase it if you need to for the final render. Save more render time.

5: In the F10 render panel there’s two boxes for Xparts, Yparts. Set them both to 1 to improve render speed even more. Higher figures are intended for sharing render buckets across CPUs or networks (I believe).

When I first opened your file, I gave up waiting for one frame to render at 50% size. With all the above things done, I get a single frame to render at 100% size in 19 seconds. Your system should be faster.

A side note: I haven’t looked at how you’ve animated the lamp but it seems you’ve applied keys to the individual object parts. This can work but I’d guess inthis case you’d be better to use an armature. Other opinions may differ.

AndyD I have fixed most of the issues i think but before i go through anothere render I do have one more question.
You Said:
2: You have an entire farm of lamps sitting below the main scene. If these are on a hidden layer at render time that’s okay but if that layer is “on” then they will influence render time for no apparent benefit.
These lights as I’m sure you know do come into play close to the end of the animation. So you i need to turn off the layer that the lights are on. Render the whole scene, and then render from 2 or 3 frames before they come in to the end. Or is there a way I can key the layer to turn on at a certin point?
One more thing.
you said
A side note: I haven’t looked at how you’ve animated the lamp but it seems you’ve applied keys to the individual object parts. This can work but I’d guess inthis case you’d be better to use an armature. Other opinions may differ.

Your right on that i keyed objects and did not use armatures. The reason is i can’t seem to find a good enough tut out there to explain armatures. I found a few that told one way to do it and a few that tell another way to do it.

Thank you very much for all your time!

Ah okay. I didn’t really look too far into it to see what those extra lamps were doing down there - I see now. With all the other changes they probably won’t make enough of a render-time difference to worry about so just leave them and render in one hit (I got around 30 seconds for the final frame with everything in it). You can always do a few test renders and compare frame times with an without the lamps (the frame render time is shown in the top-right of the render window).

One thing which does increase the render time for spotlamps is calculating buffer shadows. You could save a little time if some of those extra lamps don’t really need the BufShadow button turned on. To be honest, for this simple exercise you’re talking a few seconds here and there so it probably won’t matter much but it might be useful for future reference.

As for armatures, it takes time but you’ll get there. The trick is to combine information from different tutes till it all makes sense :slight_smile: If you follow the current character animation tutorial in the BSoD until you understand how armatures work now, then you can go back to the old docs and find a tutorial on using armatures with machines. The hard part is sorting out which bits of the old tutorial are outdated and how to achieve the same results with the new system. As I said, it just takes time.

Well AndyD i would like to thank you very much for all your help I have learned a great deal from this. And I will keep on learning untill…well forever i guess. And I’m not giveing up on armatures yet, who knows i could be the one to write a tut for future noobs on the subject that they could understand lol.
Thanks again!