Cryptomatte is using same color for different objects

Hey guys, im trying to use cryptomatte in BLender 2.8 to make a matte for my object (a box)…

But when I set the cryptomatte node to "pick’… the viewer is giving the backdrop and the bottom of my object …the same white color…


So in the picture with white background… it seems that my box doesnt have a bottom part… but its there (see picture with black background)

So is there a way to fix this? So that all colors are different… Or did I do something wrong with the setup? THe objects (backdrop and bottombox arent grouped or related)

I don’t have blender right in front of me but I think you have to bump up the levels setting in the Cryptomatte panel. The number of levels defaults to six, so any more objects than that end up sharing a color.

What is the file format you use to save your rendered image?
You need EXR multilayer with 32bits and a lossless compression, 16bits half or lossy compression is not going to work properly.

P.S.: Would it be technically possible to use lossless compression and 32bits color depth just for the cryptomatte layers but half float 16bits and lossy compression for the other layers in a single EXR? This would allow for much smaller rendered files.

Thank you for your reply

@jskksj I have tried increasing the level settings and that seemed to work…but the background is still showing as white, even though its set as shadowcatcher in the render tab… So shouldnt it be invisible in the compositor?

@SteffenD … Let me check this for sure… So the image that is being rendered, is being rendered in the output format that you set? So if I set it to TIFF… the compositor uses a TIFF ? I never realised that the rendered picture in Blender is already in the format that you set in the output field. I though this was only for exporting…

OK, so you’re using the rendered output from Cycles directly (via a Render Layer node)?

No, this shouldn’t be affected by the settings of the file format AFAIK. This comes into play as soon as you’re using a rendered image sequence from disk.
The “colors” of the cryptomatte layers aren’t “human readable” but contain non-color data to identify objects / materials. The colors you see when displaying one of the cryptomatte layers can be deceiving, some even appear completely black although they contain insane numbers like -9123415.1244 to encode the matte for the cryptomatte compositing node.

Yes I am :slight_smile:
Ok when I use it like this, myoutput setting doesnt matter…
Im running into another problem though… As soon as I play around in the compositor, and I want to re-render something (after a changed something in the model e.g)… the render starts…but its doesnt go past 0%… unless i remove all the nodes in the compositor en remake them… any idea what causes this?

Hmm… nope, never had that problem.
Can you try rendering to an image on disk (Multilayer EXR, 32bit full, lossless compression) from one scene and then composite that image in another scene (you can use the same blend file)?

Im not sure what you mean by that… you mean just rendering the image, and then saving it as Multilayer EXR, 32bit full, lossless compression)?

Yes, either from the image editor or with “render animation” (and setting up the render settings accordingly, output path, format etc.)
And then load this rendered EXR into a new compositor, either in a new blend file or in a new scene in the existing blend file.