Cryptomatte masking issue

Hi, I decided to use Cryptomatte for a first time, had a look on couple tutorials and… can’t continue because I have small issue which is not covered in tutorial or anywhere else.

I use or physical lamps or HDRI but result is always the same. I can’t pick colours because I don’t have masks no matter what I do. I have only this poor image with some lines but I can’t pick anything from there. Anyone knows what I am doing wrong?

Hi Guys, I have tried today super simple scene with only 3 objects and 3 materials but when I click pick on cryptomatte node the result is black. So is there a way to fix this?

I tried Blender 2.8 installation on default setting and Blender 2.81 build but nothing had changed.

I think it is because you didn’t set up you scenes as yet…take a look at this vid from Chris Prenninger … and see what he does…


The difference I can see is that he has more lights in the scene. I had just background light and one lamp. I watched tutorial and added spot lamp and removed background light, so now I have 1 spot and 1 sun but the result is almost the same. This time I have few blue spots on black image. :slight_smile:

Thanks for a link anyway.

Did you render out your layers from the viewport? Object / shadow/ reflection etc? Then go to compositing?

No, I followed this tutorial and there is nothing about it. It seems to be straightforward as it looks like the author did not mention anything else.

Do I need to render shadows or reflections to be able to see masks in cryptomatte?

Yes…If that is what you want to work with along with the original render, Compositor is basically just a tool to merge images with different operators, you can think of it like Photoshop layers where you add different types of layers and get a result, so it needs to have something to start with the rendered scene, then a reflection layer and a shadow layer, depending on what you want to do.

I took a look again at your images and in your second image switch the top crypto output to Composite and lower to viewer.
Control-L-Click on upper and cycle through and see if you get your images…also in the Upper Crypto…make sure to add your objects with the dropper tool like you did in the color crypto…
then do the same thing and control L click in the lower crypto and see again.

1 Like

You me telling me really basic things. I used my old setup with output nodes for AO, Depth, Shadows plus added cryptomatte to it but result still the same. I can’t use a dropper because an image is black so there is nothing to take sample from.

I will add 2 blend files with different nodes maybe someone will help me to solve this. (373.8 KB)

Ok…I just looked on your 1st Blend File, when I render it out it renders then the render view blanks to transparent…in the compositor it shows in the viewer but with the same results you were getting…when I tried the a=same setup with my version it works fine…???Does it go transparent in the render view on your end?

When you press image on crypto node then yes it show transparent. I had a try on other pc and my nodes are fine there but I can’t use it for work and I need to solve this thing on mine.

You’re not doing anything wrong technique wise.

It appears there’s a problem with using Cryptomatte and the Save Buffers Toggle (under Final Render). Once disabled, the matte data looks correct.

This should be reported as a bug.


Well, that’s what I thought, thank you Ben.

Still, I want to use this thing, what can do with it? How to go over this?

Do I need to disable one of this here? Right top? I disabled and enabled one after another but nothing has changed.

Good spot on this as I couldn’t find it…I never had it on so worked fine for me.Good Job Ben!

You need to disable this in the render settings.

I don’t believe it’s on by default so I’m not sure why you have it enabled in the first place. If you’re finding it enabled in multiple scenes then you’ll probably need to adjust your startup file.

1 Like

Ha ha, I would never know, yes I use this for my everyday renders. Many thanks Ben, finally I found a solution.

Cheers :slight_smile: