CrystalBlend V0.02 Released

I just released a Windows binary for CrystalBlend V0.02. Here is the download link:

http://www.crystalspace3d.org/CrystalBlend/crystalblend_win32_0.02.zip

Here are the changes since last version (nothing dramatic, just fixes):

  • Parenting works for objects and lights. Not yet for camera.
  • Fixed camera handling so that camera actuator is no longer required camera can also be moved using motion actuator.
  • Support for the ‘gravity’ setting in the World settings pane.
  • Physics is now also supported for lights and cameras.
  • The CrystalBlend specific cbColliderSphere and cbColliderBox are now removed. Instead CrystalBlend will look at the boundtype setting in the logic panel. Only box and sphere supported for now. In case of box the geometry will be used as the shape of the physics box. For a light and camera a default 1-sized box is used (not sure what GameBlender does here?). In case of sphere the size of the sphere will be recognized by
  • Did various fixes on the motion actuator so that location, force, and torque are now fully compatible with GameBlender. As far I know it should now work the same (with regards to direction, not with regards to speed).
  • On some older hardware CrystalBlend will now be slightly faster in the ‘goodhardware’ and ‘moderatehardware’ scenarios.

I wasn’t able to incorporate all suggestions from anyone yet. Those will be for future releases. As always comments and bug reports are very welcome.

Greetings,

Sorry no positive information :expressionless: I tryed out the start_badhardware.cmd but in the console it says “WARNING: could not load plugin crystalspace.sndsys.manager” and the window runs really slow :-?

I’m using a GeForce4 MX 440

That warning is normal. Just ignore it.

What display settings are you using? 16 or 32 bit colors? Do you have recent OpenGL drivers? Those are required to get decent speed.

Greetings,

Hello jorrit,

The framerate is faster and many new things is work fine :slight_smile:
but i maybe found some bugs:

-not work visibility actuator with keryboard sensor

-not work alpha/add width png. and tga - i dont add material, only set in
Texture face panel alpha/add and assigned a texture in Uv Editor.

-not work camera actuator with moving Empty object

-not work camera in Ortho mode(orthographics mode)

-frozen if u assigned a material to a mesh that havent uv information

-the colored material is always remain red because when i set an other
color it is not changed.

-if i dont select box or shpere bound mode, the polygon stick together
when colliding (i.e. with monkey head)


I thinking about how can easily way testing convenient and new things
that would be should in the next version:

-refresh shelf shadow on mesh (Texture face panel Light button-- Using
light for face)
-read any name of .blend file(not just normalmap.blend) from (prg
directory based on abc) or drag and drop to i.e. start_badhardware.cmd
and run .blend file.
-show framerate (fps), poly count, wireframe/textured/shaded mode
-two sided faces

bye,

edem

Hmm, tried to test it with other things I’ve built, lol but it uses too much of what blender can currently do.

Some things for the future would be…

  1. Usage of layers (or is there a better way you have in mind?) Currently, CrystalBlend will show every object no matter what layer it’s in.
  2. Oh I’d love to see menu’s being able to be done simply
  3. Scene system (or better way). Currently when I have 2 scenes in the .blend, lol it loves to show the 2nd scene instead of the 1st one… dunno why

Heh those are just extras to look out for.

Looks really nice so far. Lol, but I wish I had a better gfx card so I could see it as it’s full potential. %| Maybe I should shell out about $150-200 for a better gfx card…

Jason Lin

How do menus work with GameEngine?

Greetings,

Menus have to be faked currently by using a series of planes and mouse over sensors. It’s a very time consuming process to set them up, which is why the game engine really needs a built in programmable GUI system :frowning:

Great thanks, I had my settings on 32 colors so i changed that to 16, so now it’s “playable” but it still runs slow :-?

I’m using geforce, which is controlled by nvidia, which website is down, so I can’t get the drivers, actually the nvidia site (www.nvidia.com) has been down for a couple days now, anyone know why?

www.nvidia.com works fine for me at this moment. Maybe a problem at your side?

Greetings,

Window system is included which is useful for in-game menus

Well that was under “Various Other Features” for Crystal Space. I remember seeing some cool menu screen done in CrystalSpace (about 80% sure it was a CrystalSpace screenie), but I don’t remember where. It would great to have some type of built in functional menu, like wxpython.

Menu’s aren’t hard to setup, it’s just a pain to do it the only way that can be done now.

There’s another thing I was thinking about, but not sure if it’s doable. Currently the way blender has it is that it’s in one nice big .blend file. In other engines like CrystalSpace you have the option of separting levels, characters, etc into a zip file or something. Would it be possible to do that for CrystalBlend? This will be good for expansions so people would only have to download only a small portion instead of the whole game again (heh, current downside to making addons in blender for large games, %| well no one’s really expanded their game like that, but it’d be a nice thing to have). Lol once again all this stuff you might just want to keep in the back of your mind.

:smiley: Hehe having a nicely functional CrystalBlend always comes first.

Nvidia doesn’t work for me still, I get a page connot be found on it, also I’ve been experiencing similar to problems like, when i try to download from filefront I get the page cannot be displayed instead,when i try to login to fileplanet I get the same page cannot be displayed, my internet is only going around 500 bytes too 2kb on all downloads that should be going around 140kb (could also be caused by my USB adapter(wireless)), and sometimes will just crash for no reason, or it will stop after I start to directly download something, but other then all that my internet is fine %|

Sorry for being kinda off topic :wink:

Is the minimum size of a game made with CrystalBlend going to be around 8mb zipped? Will there be a light version? For a simple game 8mb seems to be too much and those who have the ability to complete a large scale game can probably write or use an existing engine. I just don’t want to see a switch to CrystalBlend to ruin it for the “rest of us” crowd.
As it is if the current engine is to be scrapped, current development is pretty much scrapped until CB is stable.

Amazing. I just downloaded and saw the demo, it’s truly good news for me. So far, no problem, the physics and renderer runs flawlessly on my PC. I’ll test further and report back any bugs. :smiley:

Ok, even thought some features of blender aren’t implemented yet, i know it’s just a matter of time and I am thankful for what has been done.

some questions:

  1. I am confused as to the version number of CB, the dev version is 0.99 and this build is…0.2?

  2. Is there any way to create a mouse-look demo with CrystalBlend?

While normal map is fine, displacement mapping (parallaxmapping)looks totally off.

Other than that, I have to say, great job!

It is only this big because it is not statically linked. i.e. that means that CrystalBlend is currently around 30 plugins (shared libraries) and that adds a lot of size. I suspect that a statically linked CrystalBlend will be under 4 megabytes (perhaps less).

Greetings,

0.99 refers to the version of Crystal Space that is used.

Mouse-look not yet. That’s on the todo.

Greetings,

As for the version number, yeah, I just realized it after browsing through the CS website. :expressionless:

How are you planning to incoperate mouse-look, Jorrit? A specific logic brick? or the complete implementation of Python?

I just wish this feature is implemented soon… :stuck_out_tongue:

hm… i’m probably missing somthing obvious, but i can’t get it to run.

right after the window pops up i get a fatal error message. “CrystalBlend: Missing filename parameter!”

does anyone have any suggestions? i really want to check this out :wink:

hm… i’m probably missing somthing obvious, but i can’t get it to run.

right after the window pops up i get a fatal error message. “CrystalBlend: Missing filename parameter!”

does anyone have any suggestions? i really want to check this out :wink:

Tried CrystalBlend and got some objects to appear but the rest of the screen was black (including my mesh and my skybox).

In this scene I navigate through the world by using the arrow keys to control the camera. Although the ‘up arrow’ seemed to work, neither ‘right arrow’ nor ‘left arrow’ worked.