This whole area of Blender is in desperate need of in-depth tutorial videos.

1 Like

Yes. I would like to know more about using the “Data API” mode. It looks super powerful but I have not found any way to utilize it. Nor do I have an idea where to start.

In v2.93, I have discovered that Ctrl-g does not create a Collection (group) in the Outliner, as pointed out by others. It does create a Collection in the Properties panel (under Object Properties). That is not very useful.

But, if you right-click in the Outliner panel and select “New Collection”, then drag the objects you want into that new Collection. That seems to be the best way to create a Collection. Ctrl-g should be made to do exactly the same thing.

Another little sticky point is that by clicking a Collection in the Outliner panel Blender does not select the grouped objects in the Viewport (as is what happens when clicking on an object). Instead, you have to right-click the Collection and then click “Select”. Seems clunky to me. Should be fixed.

1 Like

I just discovered this topic.

I’ve made my own system to create group (It’s an approach that looks a lot like what you find in SketchUp). (Available as a free addon)

I find it quite useful, especially for archviz.

Ex :

1 Like

Collections are not groups. Groups are related to moving things as a related unit in 3d space. Collections are about visibility and organization. They are 2 different things. If you’ve used Maya, Collections are like Maya’s Layers and grouping is like Maya’s outliner. 2 separate things shoehorned together into 1 outliner in Blender.

Select all desired objects, M key, New collection, Give it a name.

If you’ve used a blogging system like wordpress or anything with “tags”, Collections are like tags in a database. A single object can be “tagged” to be in an infinite number of collections. Collections are not groups. The most basic type of “grouping” is nothing more than “parenting”. In Maya ctrl+g just does “parenting”.

1 Like

This maybe your perception of reality, but in Blender’s case I don’t believe you are correct.

My reasoning is that when you use Ctrl-g it actually creates a collection in the Properties section. It actually uses that title.

Also, a collection CAN be used to manipulate all objects in that collection.

So, it seems that the idea of a group is synonymous to that of a collection in Blender, regardless of how Maya functions.

But the implementation in Blender has not been done very well.

I was smashing ctrl g the other day and wondered if the doc was out of date documenting something that no longer works


This behavior is not mentioned anywhere

Also I tried to instancing a collection of meatballs but it doesn’t work.

If you’re talking about for example moving all of the objects as one related unit, that’s not what’s happening. You’d just be selecting all the objects and changing their transform values each individually. To truly move them as a “group” you’d want to select the thing that represents the group concept (a group node or parent node) and just change the transforms of that one object and have all of its children/group-members follow along. Collections are not the thing for that.

Some objects can be in multiple other collections at the same time. Treating one collection as a group and doing something with them then treating another collection as a group and doing something else will give you some objects never doing what you want if you happen to have some objects in multiple collections and I happen to often have multiple objects in multiple collections for very enjoyable and convenient and helpful reasons.

1 Like

Create New Collection Ctrl-G
Creates a new collection and adds the selected object(s) to it. The name of the new collection can be specified in the Create New Collection Adjust Last Operation panel. This collection is not linked to the active scene.

_ This collection is not linked to the active scene._

This is exactly the same behaviour as in version 2.79. For some dumb reason that were called “groups” in 2.79 when they actually were collections that allowed multiple objects in multiple collections and did not have any top level group node whose transforms you could control independently of the group member items transforms (so not really “groups”).

I would think, normally, that is what you would want to happen (i.e., that each of the objects would retain it’s own transform identity). I would think that if you wanted only the group to contain the transform identity you would Join the objects as one object, and not use the concept of a group. Or am I missing something?

You are missing something. Which other 3d programs are you familiar with?

… actually take that back. That might just be your (and other people’s) personal preference. It’s definitely not mine and apparently not the preference of the authors of 90% of the 3d files I download (and I download a lot, it’s an obsessive hobby of mine to download ancient 3d files and update them to work in the latest Blender)

I’ve not seen any blender, maya, max, or modo youtuber do this on a regular basis. In a rush for an insignificant background element, sure. But for the main objects of importance, almost never. People I’ve observed and the many files I’ve inspected, there’s always parenting/grouping because if you want to go back and change some things it’s more convenient to “separate by loos parts” to turn each part back into its own object and move its origin to geometry centers… but then you have lost all the names.

Left Boot is now pilot-character.098 Sunglasses is now pilo-character.045 The hair particle system for the fluffy neck of the pilot’s jacket is no longer a particle system because you had to convert everything to polygons in order to ctrl+j join it with the rest of the character.

Blender needs container type object is still one of most upvoted proposals on RCS.

Parenting to empty is not same thing:

  • empties are hard to manipulate since you will select their children first
  • duplicating empties won’t duplicate their children so you will need to also mess with selection any time you want to duplicate

Adding to collection is not same thing:

  • collections don’t have transformation data or origin technically

Collection instances are not same thing:

  • it take few steps to create them
  • you can’t “enter” them and edit their contents quickly

Right now I’m using quick instances addon which uses vanilla blender instances, but speeds up their creation (single Ctrl+G hotkey) and makes it easy to edit their contents (you can enter them like objects with Tab). Only with these changes instances can be used as container objects.

Note that I didn’t use g word even once because once it’s mentioned these threads go in endless loops of:

  • “we already had them in 2.79” - no, they worked more like tags in other software
  • blender developers will say “we can’t check commercial software” - well, open inkscape since it’s foss, add square and circle, select them and press Ctrl+G and see what happens…

Sorry for rant, but I’ve seen so many of these threads over the years…

So just to complete my understanding, to create a Group (as opposed to creating a Collection) I would use Ctrl-g?

If so, then how would one reference the Group once it is created.

No. Blender 2.8 and higher has no groups. Only collections.
Ctrl-g creates a collection and places the selected objects into this collection
The collection is not linked to the scene.
If you want to link it to the scene you go to
outliner → blend file → RMB on this collection → link collection to scene

Neither did 2.79 even though it used the word “group”. What you just described is exactly what happens in 2.79 as well.

The easiest and closest thing to groups available is parenting (like what happens with ctrl+g in Maya)

… but you’d have to install a free addon and set the shortcut to ctrl+g yourself, or buy a much better paid addon.

1 Like

Just now noticed that When moving parent object the children still keep their original xyz after moving.

I was using blendergis and after unparenting the object went 300km away from the viewport.

That caused quite a grievance.

You can avoid this by using the option ‘Clear Parent and Keep Transform’ when unparenting.

greetings, Kologe


You were expecting something different? What and why?