ctrl-r set smooth on by default?

Hello Everyone,

According to the wiki, the default when performing a loop subdivide, ctrl-r, is smooth set to off. Is there anyway to make the default setting to have smooth on?

Thanks in advance!

Without tweaking the core code and recompiling? I don’t think so if it is actually set as default behavior… personally, smoothing is among my last steps of modeling, so I personally don’t care much about having the new loop in solid state. Didn’t even notice about it, that’s to say it :wink:


I’ll buy the code tweaking, but I really don’t get the impression that it is the same as the smooth we commonly hear mentioned. From the wiki article, it appears to be just an interpolation of where the resulting vertices are placed.

In the attached pics, the mesh on the left uses no smoothing (default), and the verts are placed directly on and edge as if drawn from vert to vert. The mesh on the right using smotth (ctrl r s with the default smooth factor of 1), and the verts are placed in an interpolated position, outward.

In a cas like this, you can see in pic 2, the results w/o smooth(ctrl-r), set smooth or sub-surf. In pic 3, the results after smooth(ctrl r s), set smooth and sub-surf.


Interesting… I barely noticed this smooth option but don’t use it, and I now perfectly understand what you meant. Apparently, no: there’s no way to set it by default, you have to enable it using [S] key, except (lol) tweaking the source code to make it behave accordingly to your needs. I would have thought, though, that it would retain the state of the option from one operation to the other, but apparently not… e.g., you activate Smooth once, and then the tool remain activated through the whole session unless you deactivate it.

I learned something, today: thanks! :wink: