Cube to Sphere morph - smooth objects


After reading and practicing a tutorial on how to morph a cube to a sphere, I came up with a problem and I did a search about morphs here, and could not find anything about this.

Well, I got to follow a tutorial but the point is… in Blender, a cube is a faceted mesh (I mean, the buttons Set Solid and Set Smooth - cube is solid). Well, when the cube morphs to the sphere, I get a faceted sphere. So, I tried to go to frame 100 (the object here is the sphere), select the object and press the SetSmooth button. It became nice, however, when I returned to frame 1 the cube was strange… So, how can I solve this problem? Apologies for my bad English and hope you can understand me?


Try ‘Set Smooth’ then click on ‘Auto smooth’:
all angles les than 30 degrees (or whatever value
you set) will be smooth. You will only see the
effect of this when you render, not in the
3D window.

Also make sure your normals are pointing the right
way (select all, ctrl-N in editmode).


Hi Chris,

Thanks for answering. It worked!! Well, but I still have a doubt in one thing… Please take a look at this screenshots of the middle of the morph animation. There are some strange forms… I guess that these “square vertices” happen because of the morph and forms involved (cube and sphere). I did just as you said and used the angle of 30 degrees with Auto smooth.

I think it is better if you see than if I try to explain… hehe…


try this:

subdivide the orginal cube a few times, apply subsurfs, then convert it to a real mesh with alt-c, then do “to sphere”.

This way you can have constant shading on the flat faces when set smooth is applied. If the corners are too round, subdivide it a few more times before converting it to a real mesh . What I would actually recommend personally is to move the vertices around the edge closer together so the corner would be sharper and poly count not too high.

I’d try playing with that angle setting a bit.


Hi Cris, hi Jack000,

Thanks for answering. I tried both methods, but playing with the angle (I tried with 40 degrees first and 20 in another attempt), but it didn’t result nicely. The problem still ocurred, unfortunately. 20 was better, but I still had the problem. However, the method with subsurf worked nicely and smoothly. The only drawback it that I have to manually adjust the vertices in the corners or subdivide more. Well, subdivision plus subsurf… whoa… demanded a little more of memory. Even for Blender to redraw the object. It took it about 5 minutes to render a 100 frames animation at 640 x 480 resolution and with an AMD Athlon 1600 with 512 RAM. Anyway, now I think I have some parameters about how to set this morph and try to play around with diferent settings. Thanks for answering!


5 minutes for 100 frames? That’s only 3 seconds per frame! You’ll see MUCH longer rendertimes than that in the future, I’m sure. I’ve had animations that took 14 minutes per frame to render.