Cube when set parent to (Bone). makes unexpected transform

hi everyone,

i came across a rig tutorial where i need to set a simple bone chain with cubes parented to them. (for hair collision)

however when i select cube -> armature. Pose mode -> ctrl P Bone
unexpected transform are applied. (cube doesnt stay in place)

now ive tried:
apply transform, apply rotation, scale,
apply all transforms to delta (to cube)
still the same problem.

curiously i tried this in 2.79b (the tutorial was also 2.7x),
the cube stays in place.

is this a known bug for 2.8? i feel that this is a rather common rig operation and shouldnt be a bug. or maybe things work differently in 2.8?

thank you very much youve all been great help and teachers to me,
yours kindly,

Not sure if this will help (since I’m in 2.79) but try using Alt+P to Clear Parent and Keep Transformation, before parenting it to the bone.

i did find a thread here dated 2 months ago. exact same problem.

it appears to be a 2.8 bug so if anyone wanna report.
im new and still learning so please bear with me.
ty and have a good day.