CUDA binary kernel not found


(maleficmax) #1

Hi! Cycles are in the main branch now, so, i think it’s possible to ask some questions? :slight_smile:
Here is mine: How can i get rid of this message and make my card work? “CUDA binary kernel for this graphics card not found”
I use this build http://graphicall.org/569
And the older build works.


(arexma) #2

Do you have a CUDA capable graphic card?
And I think Cycles needs CC 1.1+ CC1.0 is not enough - don´t know that though.


(maleficmax) #3

“And the older build works.”
Yes, the older build works perfectly witn my CUDA capable GeForce GT 240. It compiled the kernel first and then rendered. Now it just shows this error.


(arexma) #4

Right, must have overread the last sentence, sorry.

Your card only supports CC1.0 which is the bottom of the line. Currently we are at CC2.1.
It might be possible that in the newer builds a CC1.1+ command is used causing this issues.
Unfortunately I have no idea to what CC version Cycles is compliant.

First shots in the dark would be to re-install the graphics driver (the default GeForce driver contains CUDA) or try to install the CUDA SDK.


(bat3a) #5

if anyone needs cuda compiled libs, i did a build today with msvcsp1 for all arch’s: here is the link for x64 and for x86


(maleficmax) #6

Wow! That worked for me! Thank you, man, i love you! )) Really, thank you!


(MGebhart) #7

Thank you bat3a. Your compiled libs worked great with the new beta 2.61 release.


(nvasquez1623) #8

Hi. I downloaded the libs but I don’t know where to put them. Do they go somewhere in blender 2.61 or somewhere else?

Thanks for your help.


(maleficmax) #9

@nvasquez1623
2.60/scripts/addons/cycles/lib

@bat3a

Your build is great for linux too! Great work!


(Sinan) #10

@bat3a

I couldn’t get 2.61beta cycles to work with any GPU on (CUDA gave “CUDA binary kernal not found”, and OpenCL didn’t work, says I have OpenCL 1.0 and it needs 1.1). I have the latest NVIDIA Drivers for my card.

I tried your cuda compiled libs and it works! wow, GPU renders so much faster!

Thank you.


(nevbms) #11

Thank You,Malefic.Max. :slight_smile:


(bat3a) #12

@all: your welcome
they are included in my builds by default, see my signature to download :slight_smile:


(MitchJ) #13

I wonder if there was an issue with the 2.61 test build. I have a card (Quadro FX 880M) that worked great with 2.60, but not with the test build. It does, however work with the current trunk, as of yesterday. Weird.


(afranx) #14

thanks now cycles GPU go!


(Marco-105) #15

thanks for this library, u really great man !
i work one day to have it and i finally found this way, it’s very hard !
how do u did it ?

Great job…!


(Karakasimov) #16

Heyyy bat3a great job man,
but how to make it work?
i put the files in 2.60/scripts/addons/cycles/lib folder and it still have the same issue.
should i burn this 9500gt graphic card? lol :smiley:

i guess i’ll download your builds than official builds.


(J09) #17

I’m also having trouble.

I’ve got a 9600M G (9400M + 9200M) with driver version 270.41.06 in Ubuntu 11.04. I downloaded r42611 from Graphicall, but it gave me an error when I tried switching to GPU rendering mode.

CUDA device supported only with shader model 1.3 or up, found 1.1.

I then copied the libraries that bat3a provided above into 2.61/scripts/addons/cycles/lib (overwriting the existing ones), and re-opened Blender. Same error message.

Haven’t tried it in Windows yet (I know my drivers aren’t up to date in Windows).

Edit: I may have posted to early. Came across this nice summary from DingTo, which states:

latest drivers for it (270.61 works fine, older ones do not work)
I’m not sure if all the driver numberings are universal, but this may explain it. I’ll try updating it tomorrow.


(bat3a) #18

@@Karakasimov: what issue? can you post what error you got? i may could help.
@@J09:two things, first you need now to set the feature set to experimental in the render menu, then select gpu from the next menu, then cuda from the last one. second you may have to update your drivers (really man that’s an old driver, it may give you more than 20% boost performance on some cases after the update).


(dustractor) #19

@bat3a: Thanks! That got 2.61 working for me! You really saved my day. I have BW cap and so downloading the huge ‘driver’ from the invids would have taken about 10 hours!

For the record in case this helps anybody else–

nvidia driver 285.79 (i did not even the beta 290.36 )
geforce 330M (inside a 2010 MBP)
windows 7

just had to copy the libs to the right place, f8…

…and choose ‘experimental’ feature set. didn’t seem to work otherwise.


(Karakasimov) #20

@dustractor
you’re correct. i tried the 2.61 official and it didn’t work initially, but if you use cuda lib provided here, it would work on “Experimental” option only.
used on Ubuntu 11.04 32 bit