cuda error at cumoduleload illegal address

Hi,

Ubuntu 14.04
GTX 580

After working for hours today with latest git build,
I suddenly had a Cuda error.
Since then( I even restarted computer ) I can’t render anymore,
Blender just freezes, black render screen or I get an error:
“cuda error at cumoduleload illegal address”

When I render on my other card GTX 550 Ti, all is well.

I have a suspicion my GTX 580 just broke.

Anyone had any similar experience ?
Would there be a way to confirm the GPU is broken ? Some test I could run ?

Thanks
Regards
sc3*2

After compiling Cuda kernel cubin successfully, I get the error also:

“/usr/local/cuda/bin/nvcc” -arch=sm_20 --cubin “/home/sc3/build_linux/bin/2.78/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu” -o “/home/sc3/.config/blender/2.78/cache/cycles_kernel_sm20_C4E254114D445B352490F8CFF5348505.cubin” -m64 --ptxas-options="-v" --use_fast_math -DNVCC -D__KERNEL_CUDA_VERSION__=75 -I"/home/sc3/build_linux/bin/2.78/scripts/addons/cycles/kernel"



Kernel compilation finished in 184.92s.
CUDA error at cuModuleLoad: Illegal address

Refer to the Cycles GPU rendering documentation for possible solutions:
http://www.blender.org/manual/render/cycles/gpu_rendering.html

Failed loading CUDA kernel /home/sc3/.config/blender/2.78/cache/cycles_kernel_sm20_C4E254114D445B352490F8CFF5348505.cubin.
Error: CUDA error at cuModuleLoad: Illegal address

Situation is gettin worse :slight_smile:

Opening any blend file ( with GTX 550 Ti ) gives me following errors:

Error, region type 4 missing in - name:“Action”, id:12
Error, region type 4 missing in - name:“Action”, id:12
Error, region type 4 missing in - name:“Action”, id:12

and no geometry is shown in 3D View

“GTX 580” - VRAM amount? Maybe you’re hitting the memory ceiling by using new Cycles kernel?
Just a thought after reading excited posts about 2Gb being just barely enough to render default Cube and some on nvidia dev forum about sm20:
“In compute 2.x devices, shared memory and the l1 cache share the same physical memory, which is why out of bounds shared memory access causes aborts not seen on older architectures.”

Thanks for your answer eppo.

This GTX 580 has 1.5 GB ram.
I’m indeed just trying to render the default cube.

But I’m having the same issue with 2.76b downloaded from blender.org:

[email protected]:~$ /home/sc3/bin/blender-2.76b-linux-glibc211-x86_64/blender
Read new prefs: /home/sc3/.config/blender/2.76/config/userpref.blend
found bundled python: /home/sc3/bin/blender-2.76b-linux-glibc211-x86_64/2.76/python
CUDA error at cuModuleLoad: ILLEGAL_ADDRESS

Refer to the Cycles GPU rendering documentation for possible solutions:
http://www.blender.org/manual/render/cycles/gpu_rendering.html

Failed loading CUDA kernel /home/sc3/bin/blender-2.76b-linux-glibc211-x86_64/2.76/scripts/addons/cycles/lib/kernel_sm_20.cubin.
Error: CUDA error at cuModuleLoad: ILLEGAL_ADDRESS

“After working for hours today with latest git build,
I suddenly had a Cuda error…”

“…having the same issue with 2.76b…”

This sounds bad, indeed.
Only, i am not quite sure if blender.org archives do include Cycles binary kernels. If kernel is not present Cycles will try to compile one (longer wait on a first time Cycles render) and if there is some nv compiler/driver incompatibility around…Again, just a wild guess and you had them running but i’ve experienced some errors while trying out downloaded from archive older Blender version on a fresh Mint.