CUDA or not CUDA (with ubuntu)

Hello everyone,

I run blender 2.69 on ubuntu 13.10.
As I have 2 GC (Intel and Nvidia) I installed bumblebee, and I launch blender with optirun.

2 configs :

  • blender was installed from blender.org in my personnal folder. It goes fine. Blender proposes CUDA as compute device and my nvidia GC is recognized.
  • blender was installed from irie ppa. No CUDA, no Nvidia GC.

Of course, I would prefer to use the second config (auto install of new releases). Would anybody know what’s the problem ? As there is no specific message in the terminal, I suppose that blender doesn’t find CUDA in the second case. Maybe a question of path ?

Hi, cant speak for Ubuntu but my distribution Opensuse has a no Cuda version in repository.
The ppa version is mostly stone old too, my serves 2.76b. :slight_smile:
I use several Blender version, stable from blender.org, own build and builds from builder.blender.org.
Download, unzip and run.

Cheers, mib.

It seems that CUDA was not installed… How could blender (installed from blender.org) find CUDA then ?

Anyway, I typed :
sudo apt-get install nvidia-cuda-toolkit

and now it’s ok.
Thank you and happy new year

Blender from blender.org has precompiled Cuda kernels for all actual nvidia cards.
It seams the ppa version has not and for building these kernels you need the toolkit.
Good to know also for other Ubuntu user.

Cheers, mib.

Thanks for your explaination. I like to understand things :slight_smile:

Hi

got a problem compiling cuda with ubuntu, Cuda-Toolkit installed.
The 3d-View loads render kernel for ever, but in the console i found:

Compiling CUDA kernel …
“/usr/local/cuda-5.0/bin/nvcc” -arch=sm_21 -m64 --cubin “/usr/share/blender/2.69/scripts/addons/cycles/kernel/kernel.cu” -o “/home/kuibu/.config/blender/2.69/cache/cycles_kernel_sm21_AF57390CEAAC3A89F6E4F820265C115E.cubin” --ptxas-options="-v" --maxrregcount=32 --use_fast_math -I"/usr/share/blender/2.69/scripts/addons/cycles/kernel" -DNVCC -D__KERNEL_CUDA_VERSION__=50
gcc: error trying to exec ‘cc1plus’: execvp: No such file or directory
CUDA kernel compilation failed.

I installed gcc and g++ and what not, and now I’d need some help !!

Possibly an issue with the gcc version? :-
http://sidkashyap.wordpress.com/tag/gcc-error-trying-to-exec-cc1plus-execvp/

Great! Thanks!
That finally did it. (after removing/reinstalling nvidia-331 though because of an issue with nvidia-opencl).

Edit: There should be an error message in the render view where it says “Compiling… this could take a few minutes the first time”.
I waited and waited until I finally found the console-error that popped up after seconds :frowning: