cuda version on cycles rendering

Hi, I have a nvidia 210 gpu, and when I try to activate the gpu rendering it displays a message saying that it needs a cuda version 1.3 capable device and that it finds a 1.2 one

is cycles going to get cuda version 1.2 support? what is the difference?

Thank you

I have a GT 240 and now don’t have Cycles GPU. kinda bummed.


I too cannot get CUDA version 1.2 on 2.61RC1 nor the previous beta version. I had to go to and find a build which works. I have GeForce 210 and updated to the latest driver 285.58 and still no CUDA GPU on the official releases. Sure hope they will include 1.2 and earlier in the final release for those of us who have these versions.

Many thanks to the developers for their hard work.


updated to 290.36 beta and the 2xx series cards are still CUDA 1.2. No Cycles GPU joy for windows 7.

Sorry for that guys, but we decided to drop official support for 1.2 and beneath. Reasons can be found here:

Hi DingTo. I get your builds all the time.

I’m confused. I have a Quadro FX card that supports shader model 4.0 and I get the same error with 2.61 RC1. But I just downloaded a version from trunk (42540) and it works fine. What am I missing?

Here’s the link to my specs:


Little off topic, are you guys going to keep Opencl at 1.1 because at least my GT 240 has OpenCL 1.2?
that is once you guys get that working.

@cat-em-ut : great isn’t it?

it’s like a government promise to construct a new fast public road of 200 km/hour. You have a car with a 180km speed limit. but then they make the road of wet claw in stead of concrete/asphalt and cannot get the speed up well. So they force you to buy a new Mercedes or you are not allowed to drive on it.

hurray hurray

@blutarsky: hahaha

for the guys/girls wants to cycle on the lower 1.0,1.1,1.2 cards, you can either download these builds (for windows only) and it will ALWAYS be included in them, or simply add x32 or this x64 to addon->cycles-> in your favorite build and it will work (if Allah wishes).

I think a core reason why only the latest GPU’s are being supported in GPU mode is that developing with older versions in mind could slow down development and, as Brecht said in another thread, make feature development and code maintenance a bit more difficult (due to additional limitations that have to be addressed in older versions of CUDA and OpenCL).

For now, everything is supported in CPU-only mode and is already quite adequate if you’re rendering stills (which will become a bit more so for scenes with glassy materials and even animation after the planned optimization work).

I understand the need to move forward, but it just makes my animation project that much harder to accomplish. I might be able to upgrade in the future and this will all be funny in hindsight.

Thanks bat3a,

Dropping the earlier cuda versions in the cycles folder worked! Thanks for including all cuda versions in your builds.

Also , thanks to the developers for such a great release. Look forward to the final.


Also thanks to bat3a

oh yes that could be but the latest GPU (Nvidia) support shader model 5.x. I have a laptop as well and that GPU supports shader model 4.1. For heave use or rendering for many hours i wouldn’t use it or it will last a couple of months before it will burn down easy because of lack of cooling i know. only blender says it supports shader 1.2 and that is not correct.
what if cycles will support multiple GPU’s ?

I tried bat3a’s methods for getting the GPU to work with cycles on lower cards but could not get them to work. I extracted the x32 to the the folder he specified but I still go the same problem in cycles. Likewise, when I downloaded the builds I got the same problem. Is there some certain way I need to launch the builds. I just went to the folder I extracted them and double clicked the blender.exe? I realize this isn’t much info, but can anyone help me out? I don’t understand the different builds of blender very well

Hi, i have a nvidia GT 240 with drivers up to date, and the specification says " Shader Model 4.1 "

why i cant use cycles in blender 2.61?

CUDA device supported only with shader model 1.3 or up, found 1.2

Sry, my error.
According to this, mi card doesnt support 1.3

In the web says why doesnt support: “earlier cards are often slower than just using the CPU.”

But a GT240 render is much faster than a render with the CPU (in the case of the test I did earlier, a 2.8ghz i5)

I dont understand why it is not supported

Hi PiroKun, the reason is: It is better to restrict hardware when cycles starts because in the next release are more cuda features and in the next even more. Older cards don´t support these features.
My gtx 260 is 1.3 and even this card is not fully supported with all possible cuda features.
You can´t start a new render engine and support stone old hardware, the chip is 4 years old.
I buy my card last year shortly before gtx 400 comes out, damn!

Cheers, mib.

ahm, that makes sense

I hope it’s not too late to sell my 240gt, to afford it a 440gt at last

thx :wink:

and bat3a, your build works perfect with my card, its a good temporaly solution, thx!

Hey bat3a :slight_smile: you made my day, thanks!