Cursor Stuck in Edit Mode

I feel like a newb asking this but I guess on 2.8 we’re all newbs.

In edit mode, my cursor is stuck in a pseudo circle edit mode. The “normal” cursor is a circle with as + in the middle; there’s a bar up top with a field in it that lets me select the radius. I want to get out of this mode entirely but I don’t know how I entered it. I saw it when it happened, but I can’t remember the keys I used to accidentally become trapped in this mode. I have tried literally for an hour to get out of this godforsaken mode. I can’t. Help???

1 Like

Switch tools. You are probably using the circle select tool.
Check the toolbar.

That was the first thing I looked at. I use that tool almost constantly in edit mode so I’m very familiar with how it works. It isn’t that.

Also proportional editing is OFF.

This thing persists across every conceivable shortcut. I tried every single key on the keyboard with alt, shift, control, control-shift, control-alt, alt-shift, and control-alt-shift. No change. I also checked everything I could find in all the menus. I clicked everything on the screen. Nothing. I’m hoping I missed something.

In the far bottom left it says “circle select” so I’m stuck in that mode. I just can’t get out of it.

That happened to me yesterday, I fixed it by going to edit and uncheck Lock object mode.
I hope it helps :wink:

How do you uncheck lock object mode? How do I get to the check box? LOL! What a nightmare!

Edit beside File on the top menu bar!

It was checked. I unchecked it. No change. Now I can’t go into edit mode at all. Even on the drop down menu up top for mode, object mode is the only thing appearing.

Try to press W key. It is shortcut to cycle through select tools.

If you open toolbar, T column. It is the first button on top of it.
You can click on another button. Cursor or any other active tool to enter another active tool mode.

1 Like

You have saved the world! W worked! I will send you one billion dollars (in Monopoly money)!!!

Thank you!!!

Wow. Just came across this thread, thankfully. The ‘w’ helped me too.

It seems like the select modes would be tucked away when hovering or clicking on the arrow in the bottom right of the select-tool box.

What is that little arrow for? You see it on many tools but seemingly for no reason.

click & hold to get more options.

1 Like

If you go into many of the tools, such as “spin” or “shear,” you’re stuck in that mode until you click the arrow, which is “general selection” or normal mode.