curve bevel problem


As you can see in this picture I’ve applied a bevel object to a curve. However, the endpoints aren’t following the curve at all. They’re neither tangent to the vertex handles as they should be, nor are they simply pointing at the next vertex. I want them to be perpendicular so that they line up with the box on the left. Adding an extra vertex to the curve near the endpoints fixes the angle, but adds a whole bunch of geometry I don’t want or need. I could just convert this to a mesh and fix it manually but I’d rather not because that would leave me unable to edit the curve later and would be impractical if I want to be doing more of these. Any ideas?

simply rotating the handles should do the trick. When you select a curve point (or just 1 handle), press V, you can choose different handle types if it’s needed

If I rotate the handles I change the overall curvature of the mesh, which is not what I want, I like the shape as it is. While the picture above is just an example scene to illustrate the problem, in my actual project I need the curve to have an exact shape. None of the vertex handle types helped, whichever one you choose you’re either losing your curve by rotating the handle or the endpoint keeps pointing slightly upward.

As in most 3d situations you have to use a workaround to get what you want. If it doesn’t work as you want you will have to overcome it with extra points at the ends so the curve is horizontal, which it currently isn’t in your example, hence the bevel is not horizontal.

Adding an extra vertex to the curve near the endpoints fixes the angle, but adds a whole bunch of geometry I don’t want or need
What you want and what you need are usually very different

@Richard: Your post is not very helpful.


In any case, for anyone who might be having the same problem, I’ve solved it by using a nurbs spline with more vertices instead and setting the u-order to 2. It’s still not perfect and there’s more vertex tweaking involved now to fit the curve I want, but the mesh density is ok, there’s just one loop of extra vertices and when I merge with the box and remove doubles, it works fine.