Curve Deform Problem


Curve Deform doesnt work (properly) for me…

i set the mesh to [trackX], and this is my result [suzanne is selected]…

any suggestions…?


Try doing a ctrl-a (apply size/rotation) to both the path/curve and the monkey BEFORE parenting the monkey to the curve/path. This should solve your problem – atleast it works here.


umm… when i apply rotation and size to the curve, it disappears…

i enter edit mode, and i find that there is now only one CV of the curve…

applying size and rotation to only the monkey doesnt do anything…

although i found that i could rotate the monkey to face the proper direction…



  1. start with a new file
  2. Add the monkey, ctrl-a (ensures the local axis of the object and world axis are the same)
  3. Add curve and create your curved shape (make sure it is a 3d curve), ctrl-a again
  4. Parent the monkey to the curve with the curve deform option.
  5. works perfectly here :smiley:


I’ve had problems working with curves & deformed meshes that tend to extend more on the Z axis, rotating everything (before parenting) to extend along the X axis instead made for a quick fix; going from advice I’ve seen posted about using tracking on X axis for the deformed object & what’s been said here.

This bit mentioned there is enlightening but esoteric until you get your hands dirty:

3D on/off

In Editing Context (F9) buttons for the Curve; this will allow to make 3D curves. It has the same limitations as for ‘curve follow’, where you have to avoid a straight line up in the Z direction to prevent flipping.

Great tool but a bit awkward, it does work perfectly well once things are positioned properly.

Just my own little bit to add from personal experience, sorry for the stream of consciousness cadence.


i really cant blend right now, but i think its because i didnt have the 3D button on…

thank you


The Curve Deform, I think, is really sort of counterintuitive. So I’m going to write a mini-tutorial here that I figured out from messing around a lot in the hopes that it will help someone.

In Top View, add a Monkey.
Select all of the Monkey’s vertices (obviously still in Edit Mode) and rotate them 90º about the Z-axis. (If you were still in Top View, just rotate them 90º.)
With the Monkey selected, go to the Object Buttons and set TrackX.
Add a Curve, again in Top View (I usually use Bezier, but to each their own).
Select the Monkey, select the Curve, Ctrl-P, and choose Curve Deform.

If you want to, which you probably do, select the Curve, and set 3D in the Edit Buttons to allow vertical control-point movement.

Now the curve should deform the object. If it doesn’t, I either wrote something wrong, or you missed a step or something.

I’m sure this could be done in other ways to allow different orientations, so just mess around and you might make something of it. This is just what I got after about 10 minutes of experimentation. Good luck!

thanks for the mini-tut, DVirus (even though it didn’t solve my problem…)

setting 3D on for the curve doesn’t help, but i figured out another way to make it face right…

thanks for all of your help, guys…