Curve extrude bevel different 2.82a and 2.83.x!


When importing a svg, extrude and use bevel the result in 2.83 isn’t the same as in previous versions.
2.83a and backwards it’s a sharp bevel and in 2.83 it’s kind of stretched. Even the flat surface becomes affected.
Anyone noticed this?


svg-2.82_vs_2.83.blend (620.7 KB)

Yes. In 2.82, bevel is a separated part of interpolated mesh.
In 2.83, a developer choose to make extrusion and bevel parts a unique one.
As a result shading is smoothed along the all part.

You can still retrieve the old look by adding an edge split modifier.
But that does only work for angle value setting.
If you want sharp edges with a rounded profile, you have to convert curve to mesh.


@zeauro Thanks, that fixed it.

Though it seems unnecessary to need to use an edgesplit modifier to get a clean straight bevel.
It should be some on/off box to toggle alongside the curve extrusion/bevel area for hard/smooth bevel or something.

It’s dangerous to be away from Blender longer periods… shit happens and you find yourself a bit lost :nerd_face:

Thanks again :+1:

Doesent right click shade smooth work?

In object mode.


No, that’s how it is by standard now.
“Shade Flat” brings back the sharp bevel but then some surfaces looks bad (center hole).


ok thanks ?

1 Like