Curve Modifier distortion problem

Im attempting to plot spheres along a basic bezier curve, I’ve followed several tutorials but I cannot figure out what Im doing wrong here…

  • I created the bezier curve
  • Created a sphere
  • Applied an array modifier to the sphere

  • Applied a curve modifier to the sphere … but the spheres flatten (wont maintain shape)

Im sure there’s an easy explanation but I could use some guidance. I’ve followed several tutorials painstakingly and I cannot understand why im getting these results???

You haven’t included an example .blend so don’t expect an answer why your setup behaves like it does. The set deform axis looks wrong but there might be something else going on.

Curve modifier is a deform modifier, so it will distort the meshes. Use frame duplication if you don’t want that to happen.

1 Like

Ok thank you I will try all of this!

@JA12 here is the example file Study_CurveArray.blend (451.0 KB)

I looked at the file. You have some transformations on the curve. The scaling is not set to 1,1,1 and path deform is turned on on the curve.


  1. Select the curve
  2. Apply the scale control-A
  3. Select scale from the list
  4. In the properties panel choose curve and turn of radius in the Path/Curve deform options in the shape part.

Happy blending!

1 Like

Thank you @Lump that pretty much solved the problem, very very much appreciate the guidance!

1 Like

Same with visuals

  1. The curve scale is non-uniform and unapplied
  2. This is what the modifiers see

Applying the scale transfers the scale to the curve radius. Either would have to set the radius in edit mode (W -> set radius, for the selected), or disable radius from curve properties.

The curve direction is from left to right, so would have to switch it in edit mode. The array goes to +x, but the curve is at -x. There’s also an offset between the two objects.

Moving, taking care of the radius after applying the scale, and making everything point to the same direction, it starts to make sense.

Or could use the mentioned frame duplication. Check the manual how to set it up but basically: parent the dupli-object to the curve, set curve path animation amount and enable follow. Enable frame duplication for the dupli-object from object properties, disable speed, and set the end to the same value as the path animation.

Study_CurveArray_ja12.blend (131.8 KB)


Thanks @JA12 your visuals are really helpful, I wasnt clear why applying the scale helped and you cleared that up beautifully.

Im going to try the frame duplication version with your instructions next.

Cant thank you enough!